This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Antony Nikrooz 2 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 12, 2019 at 5:16 pm #4382707

Antony Nikrooz

This is a multisite set-up. Main site working fine, this sub-URL site is not.

I am trying to:
Translate a post - either as admin through posts or using translation management as a translator. This works fine. Post shows checkmark Complete. But the language switcher on the post does not show the language.
Tries cache clearing etc. as detailed here: https://wpml.org/forums/topic/content-of-translated-page-not-showing/

Link to a page where the issue can be seen:
hidden link

I expected to see:
Language switcher showing languages this post is translated into

Instead, I got:
Just English in switcher. Going to eg. hidden link just gives a soft 404.

August 12, 2019 at 9:08 pm #4383701

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 13, 2019 at 5:51 pm #4390101

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and noticed all your secondary languages are marked as hidden in your provided test website from your WordPress Dashboard > WPML > Languages > Hide Languages for test purposes I unchecked the french and persian languages from the list of hidden languages and you can notice the languages appear as avaialable at: hidden link. It should be the same cause of your issue in your production website. Please, check it and let me know the results, have a nice day.

August 14, 2019 at 8:26 am #4393369

Antony Nikrooz

Ha, knew it must me something simple! Thank you 🙂