This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 11, 2018 at 12:11 pm #2808052

a.j.

I am trying to:
remove wrong permalinks

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
both links are to same post. post has no translation.
i expect spanish link to redirect to english link (original post)

Instead, I got:
spanish link is valid and opens english post.

October 12, 2018 at 4:31 am #2810746

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

It seems that the posts are set to 'Translatable - use translation if available or fallback to default language'.

To change this behavior I kindly ask you to go to WPML -> Settings -> Post Type Translation -> Set 'Posts' to 'Translatable - only show translated items' -> Save the changes.

Could you tell me if the issue is solved?

Kind regards,
Carlos