This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by karolyS 3 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
May 4, 2019 at 7:08 am

karolyS

Hi WPML Team,
Just finished importing products with WP All import (using with the related wpml addon).
After I finished with the import the whole website is drastically slowed down/crashing (front and back-end but for now i'm working only on the back).
I getting the error:
preg_match(): Compilation failed: regular expression is too large at offset 46629 in /home/koukosma/public_html/wp-content/plugins/wpml-string-translation/inc/admin-texts/wpml-admin-text-functionality.class.php:99

I'm using 2 languages: English (admin language) and Greek (shop default).

Query Monitor installed and enabled for debug.
PHP verison 7.0.19
WordPress, WooCommerce, WPML plugins are all updated to the latest version.
I was able to backup the db and website through cPanel.

I searched the forum on similar problems but didn't find applicable solution.

Any help would appreciated,
Karls

May 4, 2019 at 12:45 pm #3740317

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us. I'll ask the developers team about the error, but could you tell me what do you have in wpml-string-translation/inc/admin-texts/wpml-admin-text-functionality.class at line 99?

May 4, 2019 at 1:20 pm #3740355

karolyS

Hi Laura, thanks for taking a look and forwarding my issue.
Personally I have nothing in this php class but only the preg_match() expression that fails for some reason.

May 4, 2019 at 5:31 pm #3740875

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Ok, but what does the file say? It does exist?

May 4, 2019 at 6:14 pm #3740897

karolyS

Of course it's exist. It's a main component file (class) of your String Translation plugin. The line 99 is:

		return array_key_exists( $option_name, $black_list )
		       || preg_match( $matcher, $option_name ) === 1;

within the class WPML_Admin_Text_Functionality.
🙂

May 6, 2019 at 2:38 pm #3750009

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I was asked to escalate the issue so I'll need a copy of your site. I'll send you instruction shortly, please let me know when it's ready.

May 6, 2019 at 2:45 pm
May 8, 2019 at 8:02 am #3764387

karolyS

Hi Laura,
Sorry for my late reply. I'll complete the migration to the Cloudways today.
thank you,
Karls

May 8, 2019 at 9:27 am #3765029

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Karls,

no problem (I don't work on Tuesdays anyway), just let me know when it's ready.

May 8, 2019 at 11:19 am #3765899

karolyS

Hi Laura,
Before yesterday, I migrated (upgraded) my website to a powerful server but nothing changed.
Now, I migrated the website to Cloudways with the provided connection details (db username and password didn't asked).
Before I started I needed to disable all wpml plugins, otherwise my admin panel was very slow, after selecting anything in wp admin, started to respond only after 2min.. Disabling the main wpml plugin the speed is goes back to normal.
Thank you,
Karls

May 8, 2019 at 2:57 pm #3767977

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Karls,

thanks for the copy, I checked it and there are issues indeed.

I escalated the ticket to the 2nd tiers, I'll let you have news as soon as possible.

May 14, 2019 at 4:32 pm #3809167

karolyS

Hi,
any update on my performance issues with WPML core plugins?

May 15, 2019 at 6:09 am #3812449

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I have no news at the moment, our 2nd tiers have a long queue so it's not possible for them to fix everything quickly.

May 23, 2019 at 2:13 pm #3876457

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we found the issue with imported products. WordPress has a limitation of 32 chars of taxonomy title, and WooCommerce adds some characters to that and limits it further.

For example, pa_application-temperature-ambient is one of the taxonomies you have. pa_ is automatically added by WooCommerce, and it's something that cannot be avoided. In total, the taxonomy has 35 characters, hence the error.

So you should change the attribute length before importing products, as you can see it can cause errors. Most likely fixing this will also solve your performance issue.

Unfortunately, since this is a WordPress limitation, we can't offer a better solution.
Let me know if this helps you or if you need further assistance.

May 23, 2019 at 6:36 pm #3878799

karolyS

Hi Laura,
thanks for the reply and for the support team for the effort to investigating my issue.
Quick question: Can I edit these "long" taxonomy titles in the current installation from the back-end and/or from the database and translate (edit the translation) them after?
I'm trying really hard to avoid the re-importing.