This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Lauren 3 months ago.

Assigned support staff: Lauren.

Author Posts
July 16, 2019 at 3:41 pm #4221983

patriciaO-4

There is a page that displays jobs dynamically from a separate table within the database, we use rewrite rules to accomplish this. These urls are of the format

hidden link

I can preserve the parameters in the querystring, but it's the /job/ part. Job is a page within wordpress using a custom template, the content of the template uses the jobId as the identifier.

When I click to view the Spanish version of the page, the url changes to

hidden link

Notice /job/ has changed to /trabajo/?

I don't want that, I want the url to stay the same so

hidden link

Can I do that?

Thanks

July 16, 2019 at 4:28 pm #4222319

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please run a search in the database for the string hidden link, and maybe that will help us determine where the translation is coming from. Let me know the results.

July 17, 2019 at 8:24 am #4227387

patriciaO-4

There are a couple of interesting lines

String job
Job %1$s: %2$s - %3$s

I have highlighted the latter in the screengrab attached

July 17, 2019 at 2:34 pm #4231279

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

July 17, 2019 at 2:51 pm #4231415

patriciaO-4

The job urls can be found by clicking job search, then any of the jobs in the list.

July 17, 2019 at 3:22 pm #4231747

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I think the issue was coming from the translated page for Job. I saw that the slug for that page was translated to trabajo. I changed this to "job" and now the page loads in the Spanish URL for me: hidden link

Please let me know if you need any further assistance and I will be happy to help.