This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Bruno Kos 4 months ago.

Assigned support staff: Bruno Kos.

Author Posts
May 22, 2019 at 1:33 am #3859553

corinneH

Hi all, have had a whole bunch of translations done with XLIFF import, they are all marked as complete, I can click edit transaltion and see the translated content BUT how do I view the page?? It is published but if i go in admin to page it doesnt show the transaltion editor it just shows a bunch of yes/no fields and if I click the permalink the page is empty?? I am sure it's something simple like a checkbox not ticked somewhere 🙂

May 22, 2019 at 7:21 am #3861849

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

If I got this right, I would say that the easiest way for you to view any translated content is to open any post type, change the language and the view pages. Or set a language switcher either in widget, menu or footer, open page originals and then change languages using switchers.
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Regards,
Bruno Kos

May 22, 2019 at 9:28 pm #3869343

corinneH

Hi Bruno - thanks for the fast response 🙂 Still not seeing any translations though. Have tried viewing by visiting the English frontend version and adding "?lang=de" to the url (produces page not found page), going into admin in German and clicking view (produces empty page). The translation is there (can be seen from English admin and clicking edit translation) so something isn't turned on somewhere?? Any help greatly appreciated 🙂

May 22, 2019 at 10:03 pm #3869591

corinneH

They don't actually have a language switcher configured yet - could that cause the issue? I would have assumed you could visit a page by adding the necessary lang to the URL without a switcher yet?? Worth mentioning.

May 23, 2019 at 9:07 am #3872797

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Based on these images - you can click the links of translations, but they seem to be empty, even though the translation has been filled in properly?

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

I see the following though - Support for site under development - so is the site available on a live or staging domain perhaps?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 27, 2019 at 10:09 pm #3901141

corinneH

Iam just waiting on the server guy to add the language switcher so I can discount that as an issue - I'll get back to you. Thanks for your help so far 🙂

May 28, 2019 at 9:09 am #3904583

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Sounds like a plan!

Regards,
Bruno Kos

June 3, 2019 at 8:58 pm #3946141

corinneH

Morning Bruno - we managed to narrow it down to not being the language switcher (we enabled it in a hidden div). We set up a test server if you could send me one of those credentials forms again. If you could login to the admin and test the Spanish article please. Thanks.

June 5, 2019 at 8:13 am #3957855

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Your next reply is marked as private again!

Regards,
Bruno Kos

June 6, 2019 at 12:03 pm #3969011

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me if this is the website where I should be seeing the issue? I've opened Pages and what I see is different than the image you have provided before - there are no all those languages or responding translations.

Regards,
Bruno Kos

June 6, 2019 at 8:35 pm #3971935

corinneH

Morning Bruno - that test server only has a few articles on it. It's the "Support" article you can use to check settings as it exists in both english and spanish. The real website has thousands - none of which are working - but has the same configuration as this test server. The language links are in the footer (the ones in the header should not be used).
Is there anything that you can see that would stop the wordpress display loop? We see the header and footer but no content on spanish.

June 7, 2019 at 8:05 am #3974603

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've spent some time in the back end of the website, trying various things related to custom fields and their translation preferences. It is not working for new pages either, so I am suspecting that this might be a compatibility issue. Can you tell me if you created all those custom field groups by yourself, or have you imported them through the theme?

I would like to test this theme on our clean sandbox if you agree, where we could exclude any other possible culprit, such as interference from some other plugin, etc.

Let me know how complex it is to install this theme and import custom fields - if this isn't very time-consuming, let me know and I will set up a clean sandbox WordPress installation for you.

Regards,
Bruno Kos

June 13, 2019 at 9:38 pm #4016971

corinneH

Morning Bruno - sorry for the delayed response. We have finally managed to get this working in a test environment 🙂 But can't seem to replicate it to a production server. The trick is to open the translated page with the default WordPress editor and you can see the translated custom fields - save it. So obviously the automated creation of a post is missing something that actually saving it fixes. BUT when we open the translated page on the live server we can't see the fields (which I know is an ACF error). But I suspect an unnecessary WPML setting is causing this. When I look at ACF field groups on test I don't see languages across the top - yet it works. On the live server I do see languages across the top but it doesnt work??

June 14, 2019 at 6:24 am #4018707

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

When I look at ACF field groups on test I don't see languages across the top - yet it works. On the live server I do see languages across the top but it doesnt work??

The setting which controls this is:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-field-groups

"To translate the Field Group, follow the steps below: Set the “Field Groups (acf-field-group)” post type to be translatable by navigating to WPML -> Settings and scroll to the Post Types Translation section."

So if set to "Not Translatable", you will not see the list of languages in the Field Groups section, as per your image. Can you try with changing this on the production site?

Regards,
Bruno Kos