This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bigul 2 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
July 23, 2019 at 3:07 pm #4267271

markusG-31

First of all: We have switched our WordPress installation from hidden link to hidden link. There is a 301 redirect.

I am trying to:

WPML is configured to "A different domain per language". We have configured the following:
English: hidden link
German: hidden link

We've re-saved the perma links, and logged out and in again.

Now, we are trying to edit and preview pages (already published and drafts), but this doesn't work.

It doesn't matter on which domain (language) we're trying to preview a page: It always fails to automatically update the page, when you click on "Preview" in the right top corner with the following error message on the page edit site:

> Updating failed

And the preview - which opens in a new tab - is just generating the preview, but does never end and show it.

Link to a page where the issue can be seen:

You need to be authenticated in WordPress to be able to see it, so I can't provide you a page, where you can see it.

One preview link was for example this one: hidden link

The interesting thing is, that I can view the page, when I remove the last two GET parameters of this preview URL: &preview_nonce=71cae84607&preview=true

So this preview URL is working: hidden link

Seems like as WPML links the preview button wrong or these parameters are not handled correct.

I expected to see:

The preview of the already published or draft page in the correct and expected language.

Instead, I got:

The error, that I am not authorized to see the page. The exact German error message is the following:

> Du bist leider nicht berechtigt, Entwürfe anzusehen.

Translated into English, it should be something like this:

> I'm afraid you're not authorized to view drafts.

We researched about this issue now the last days, but we couldn't find any solution, which solved our problem. We have tried everything, what we could find:
- Defined the site URLs in WordPress as well as wp-config.php
- Updated memory limit in WordPress to 512 MB
- Updated apache vHost configuration

We are currently using the latest supported WPML version 4.2.6 on WordPress 5.2.2.

July 23, 2019 at 6:22 pm #4268613

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please upgrade to the latest version of the WPML(4.2.7.1) after a full site backup and make sure you are still having the issue or not.

If the issue exists, please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

July 24, 2019 at 9:46 am #4272569

markusG-31

Hello Bigul,

Thank you for your reply!

We have updated the WPML plugin to the latest version 4.2.7.1, but we're still experiencing this kind of issue. Nothing changed.

We've also added these lines to our wp-config.php:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', true);

You can find our debug.log here: hidden link

While testing the issue, WordPress did NOT display any further error messages and it did also not generate anything to the debug.log file.

Something else seems to cause a SQL deadlock, but this was not caused by our issue here - those timestamps differ 5 or more minutes from the time, where we tested it.

I've now disabled debugging again, that this file does not increase further.

Best Regards,
Markus

July 24, 2019 at 5:48 pm #4276713

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Markus,

Thank you for the details. Please deactivate WPML for a moment and check you can preview these pages.

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

July 26, 2019 at 12:35 pm #4289631

markusG-31

Hi Bigul,

i deactivate the WPML PlugIns. Now i have white Frontpages and also a white Preview in the Backend. After reactivating the Plugin my WP starts to build URLs like this: hidden link what is the _ga= variable? Do you know from what is it?

July 26, 2019 at 4:50 pm #4291079

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Markus,

Thank you for the updates. This may be a compatibility issue. Just to make sure, have you tried the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

August 2, 2019 at 6:26 am #4327171

markusG-31

Hi Bigul,

We're checking the whole wordpress right now. Please do not close the ticket yet, we will report next week after checking the system.

best,
Markus.

August 2, 2019 at 3:04 pm #4330979

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Markus,

Thank you for the updates. We will wait for your feedback. Take your time.

--
Thanks!

Bigul

The topic ‘[Closed] Preview page causing unauthorized error with multiple domains per language’ is closed to new replies.