This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Default curency applied in WooCommerce settings for each language is not working

Solution: WOOCS - WooCommerce Currency Switcher" plugin is conflicting with WPML disabling the plugin solved the issue.

Author Posts
April 24, 2019 at 4:12 am #3669203

marianaA-3

I am trying to: switch from "mexican pesos" tu "us dollars"

Link to a page where the issue can be seen (im testing this only on the following product. I want to make sure this works correctly first before I go ahead and translate all the products): hidden link

I expected to see: when I swtich my website to english language, the product price should change from "mxn pesos" to "us dollars", sometimes it does respond correctly and other times it fails, i really can not be having this issue with the customer....

Instead, I got: it is not switching currency price correctly....

April 24, 2019 at 10:18 am #3671493

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum, It seems like the multicurrency is not configured properly or any of your plugins is conflicting with the currency conversion which I am not sure.

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Kind regards
Raja

April 24, 2019 at 4:52 pm #3675371

marianaA-3

Also another question, why are my "string translations" (traducciones de cadenas) in english by default when they should be in spanish by default with the option of translating strings into english?

April 25, 2019 at 10:16 am #3681059

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

You have "WOOCS - WooCommerce Currency Switcher" plugin installed and active which might be conflicting with our Multicurrency setup. Try disabling the plugin check whether you still have an issue.

This seems more like a plugin conflict if disabling above plugin doesn't solve the issue Could you please confirm that the problem still exists if you turn off all non-WPML related plugins except woocommerce? .

Please let me know the results

Kind regards
Raja

April 25, 2019 at 4:32 pm #3684517

marianaA-3

Hi Raja,

I think the issue has been resolved!! I guess the plugin "currency switcher" was the one conflicting with WPML! Im so happy, thanks so much for your help!

As to my other questions, what do you suggest to fix the following points:
- shouldn't the string translations be in spanish by default, with option of translating into english (the secondary language)?
- could the flags be changed?

Looking forward to your kind reply.

Thanks.
Mariana

April 26, 2019 at 7:48 am #3688525

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marina,

Thanks for the update, Glad your issue is solved.

Regarding the string translation, It depends on the content of the string if the registered string is in Spanish then it is good to change the language to Spanish. Al most all of the plugin and theme has english strings as default.

- If you feel the language to be changed for certain strings, Goto String Translation table, Select the string and at the bottom of the table, there is an option to change the language of the selected string. Choose the appropriate language (Swedish in your case).

- If you prefer to change the entire domain to some other language, In String translation table, Click on the "Languages of domains" located just above the string translation table. A popup will open to choose the language of the domain.

I hope this helps you better.

kind regards
Raja

April 26, 2019 at 4:57 pm #3692467

marianaA-3

Hi Raja !

Thanks so much for your help again, i got it now and learned a lot from your assistance =) My issue has been resolved completely !

On the other hand, a little bit of bad news, my client just contacted me and decided that she doesn't want her website translated anymore =( .... So i would like to unregister WMPL from this website: hidden link , so that I can use this liscence for another website in the future.

What do I have to do to unregister WPML plugin from hidden link and keep this liscence for a future website, since Im aware the plan I purchased only covers 3 websites in total.

Thanks and sorry about that.

Mariana

April 26, 2019 at 5:08 pm #3692521

marianaA-3

What I did to unregister website was deactive all WMPL plugins and in WPML Multilingual Plugin clicked on "cancel registration for this website" , did I do the correct thing?

April 29, 2019 at 4:22 am #3699937

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mariana,

If your client decided not to translate the site anymore and want to remove WPML completely,
You should be using the WPML reset option to delete all translation and WPML completely.

Go to WPML->Support->Troubleshooting (the link is above the info table). In troubleshooting page, click on “Reset all language data and deactivate WPML”. This will remove all the database tables and records related WPML

After that, you can unregister the site from your wpml accounts dashboard as you have mentioned in your earlier response.

We highly recommend securing a backup of your site and database before deciding to completely remove WPML.

I hope this helps you better 🙂

Kind regards
Raja

April 29, 2019 at 8:39 pm #3706579

marianaA-3

My issue is resolved now. Thank you!