This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 3, 2019 at 2:43 pm #4688839

gaborK-9

I am trying to: Fix the issue of my default language prices in the database postmeta _price field are getting rewritten to the foreign language price.

Link to a page where the issue can be seen: A custom cron job is set up to revert default language prices back to the original using the regular price. That's why I can't show an example of this.

I expected to see: prices are as they are set at the product level for the default language and for foreign languages they are calculated with the fixed conversion rate.

Instead, I got: default language prices are set to be the same as the foreign language prices calculated with the fixed conversion rate.

October 4, 2019 at 12:03 pm #4695525

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.
- Flush any cache memory that might exists.
- Go to WPML -> Support -> Troubleshooting link -> Apply the steps highlighted in the attached image.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options and click no the 'Start' button.

Could you tell me the results of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos