This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.45 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The prices of the variable products are not synced between languages. When we edit a price, It does not change in all languages. Solution: The issue is caused by the failed synchronization of the product attributes. To fix it press the "Synchronize attributes and update product variations" button.

This topic contains 14 replies, has 3 voices.

Last updated by Adrien Lamotte 1 month, 2 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
January 22, 2018 at 6:50 pm #1492627

Adrien Lamotte

Hello,

The prices are not sync between languages. When we edit a price, It does not change in all languages ! This cart price change also when I switch language.

Link to a page where the issue can be seen:
EN version : hidden link
FR version : hidden link

I expected to see: same prices in all languages

This is urgent because the prices showed on my website are wrong.

Thank you !

January 23, 2018 at 3:10 pm #1494040

Francesco Di Candia

Hello,
I was checking the link but I'm not able to access the FR product.
Can you check it, please?
Can you please send me some more information about the way you create and translate/duplicate the products with the variations?
Can you confirm that, to create your products/variations?, did you use the instructions on this page https://wpml.org/documentation/related-projects/woocommerce-multilingual/?
I look forward to hearing from you, Francesco

January 23, 2018 at 3:29 pm #1494090

Adrien Lamotte

Hello !

Yes, we had to close the french version because the prices are wrong...
I join you a screenshot of the french version of the page.

I join you also a screenshot of a message in WooCommerce Multilingual > Attributes page. Maybe it's related ? But when I it the button "Synchronize attributes and update product variations", it run a long time an results in a ERROR 500.

Hope this will help you.
Thank you !

January 23, 2018 at 3:52 pm #1494135

Francesco Di Candia

Hi, to help you I've to ask you to send me a debug.
can you please enable the WordPress debug mode?
- Open the wp-config.php file that is inside your WordPress root folder and search for this line:

define('WP_DEBUG', false);

- Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Now the errors will be logged in the debug.log file inside /wp-content/ folder.
Try to recreate/sync the attributes between the variations, to record the issue in the log file.
Now, please post the content of wp-content/debug.log file here in the forum or on pastebin.com if it is too big.

Related documentation:
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress

January 23, 2018 at 5:08 pm #1494280

Adrien Lamotte

Here is the content of the debug.log after sync error :

[23-Jan-2018 17:02:53 UTC] PHP Notice:  WC_Cart::get_cart_url is <strong>deprecated</strong> since version 2.5! Use wc_get_cart_url instead. in /var/www/vhosts/capulette.com/httpdocs/wp-includes/functions.php on line 3839
[23-Jan-2018 17:02:54 UTC] The WC_Cart::get_cart_url function is deprecated since version 2.5. Replace with wc_get_cart_url.

Thank you !

January 24, 2018 at 7:55 am #1494857

Francesco Di Candia

Hi Adrien, thank you for the information.
I will need access details to check further.
Can you share them below? I have marked your next reply as private

Thank you, Francesco

February 1, 2018 at 5:46 pm #1504472

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Vincenzo.
Since Francesco is not available, I will replace him here in the forum.
I hope this is OK with you.

From what I can see, the issue seems to be caused by the failed synchronization of attributes.

The WordPress debug log is not showing the cause of the Fatal error during the synchronization. The fatal error seems happening after 45 seconds.

1. The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.

Add this to the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

You can check the current WP Memory Limit value from WPML -> Support in the Info section

More info here:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
- https://wpml.org/home/minimum-requirements/

2. Can you please ask the hosting support to verify the web server error log for any hint about this issue?

3. Please check if there is some time limit set in the php.ini file or somewhere else that stops the synchronization process at about 45 seconds after it starts.

4. Please update all the WPML plugins to the latest versions.
- It is important to update WPML Multilingual CMS before any other addon plugin
❌ Before proceeding please make a full website backup! ❌

You can check the latest released versions under “My Account -> Downloads” on this site.
- https://wpml.org/account/downloads/
Instructions to update can be found here:
- https://wpml.org/faq/install-wpml/#automated-updates

Thank you

February 2, 2018 at 11:10 pm #1505951

Adrien Lamotte

Thank you for your answer.

I increased the memory limit to 512M, and update all the WPML plugins but the request still timeout...

Any other idea ?

February 3, 2018 at 2:30 pm #1506157

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

1. Did you check the web server's error log?
- You may be able to check that from your hosting panel or you may need to ask for it to the hosting support.

2. Did you increase the max_execution_time in the php.ini file?
- I still see that the Fatal error happens after precisely 45 seconds
- Sometimes there are other parameters that can interrupt a script execution. Please ask to your hosting provider for more information.

3. To further debug the problem I’d like to replicate your site locally.

I would need a site snapshot if possible.
We usually recommend the free Plugin “Duplicator” for this purpose.

If you already know how Duplicator works
(https://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the archive file you downloaded.

★ Duplicator Instructions
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

If the file is too large (more than 200M), please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media and the archive files.

Send me the archive file (you probably want to use Google Drive, DropBox, or similar services, as the snapshot file will be quite big)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.
Once the problem is resolved I will delete the local site.

Please let me know if you need help creating the Duplicator package.

Thank you

February 13, 2018 at 12:43 pm #1516158

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I installed the copy of your website on my local server.

1. I was able to complete the synchronization without any issues on my local server. Please check the attached screenshot.
- Please ask your service provider to increase the PHP execution time and any other similar settings that are limiting it to 45 seconds.

2. I can see that in the French version of the Big Blue product there is a "Promo" enabled that changes the price.
To fix that I used these steps:
- Go to WooCommerce -> WooCommerce Multilingual -> Settings
- Enable the "Native WooCommerce product editing screen" option
- Save
- Go to the English Big Blue product edit page
- Edit the product price
- Update the product
- Edit the French translation
- Save the translation

This fixed the issue with the price difference between languages

3. I can also see some error in the language of the registered strings (eg. Taille)
- You can solve it by disabling the "Assume that the original language of all strings is English" option in WPML -> Theme and plugins localization" and changing the language of the registered strings from WPML -> String Translation

Please let me know if this solves the issue or if you need further details.

Thank you

February 17, 2018 at 12:10 pm #1520942

Adrien Lamotte

Hello,
I'm still waiting for an anwser of my host provider. I'll let you know.

And thank you for your previous tests !

February 19, 2018 at 3:56 pm #1522469

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I will wait for your updates.

Thank you.

February 23, 2018 at 9:45 am #1527276

Adrien Lamotte

Still invastigate with my host provider...

February 23, 2018 at 10:21 am #1527330

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you for the update.

I will wait for the results.

Please let me know if I can help in some way.

Thank you

September 2, 2019 at 1:50 pm #4497465

Adrien Lamotte

Hello,

We have the same problem again, with the latest versions of the plugins. The french prices are not up to date.
As you can see on the screenshots, the french price is locked but not synch (there is still a sale price).

Thank you for your help.
PS: Do we need to open a new issue ?

Regards,
Adrien