This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 2, 2019 at 2:52 pm

stefanijaV

I have used hidden link plugin to bulk edit prices on my site. The sites default language is English and secondary language is Latvian.

The prices show as expected on the English version, but when translated to Latvian the prices change.

I have not set different currencies or anything the like. The default currency is EUR.

Hope you can help.

July 2, 2019 at 3:59 pm #4128593

stefanijaV

Secondary login peachyadmin; password is the same

July 2, 2019 at 4:54 pm #4128947

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I tried to log in the site but the credentials failed. I have set your next answer private so you can provide new credentials to access the site in a secure way.

2.- Please describe the steps to reproduce the issue.

Kind regards,
Carlos

July 2, 2019 at 4:59 pm #4128967

stefanijaV

hidden link
1.
***
***
2.
***
***

On enlish site click "new in" - see prices. Then change language to Latvian - see prices. They are different.

July 2, 2019 at 5:07 pm #4129077

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for you message.

1.- I'm sorry but I still can't log in the site using the credentials provided. I have set your next answer private again.

2.- Please follow this steps and let me know the result:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options -> Click on 'Start' button.

Could you tell me if the issue persists?

Regards,
Carlos

July 2, 2019 at 6:01 pm #4129279

stefanijaV

Hi,
Sorry I think the second password for *** is ***

I did all you asked and the problem persists.

July 2, 2019 at 7:18 pm #4129667

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

This time I was able to log in the site. I applied several troubleshooting steps and now I can't see the issue.

Could you confirm that the issue disappeared? If the issue persists please provide the steps to reproduce it.

Regards,
Carlos

July 2, 2019 at 7:31 pm #4129733

stefanijaV

Hi. Glad to hear so.

Unfortunately it still persists, but what is weird is that after the troubleshooting some prices got fixed but when you press to load more products in the new in section for multiple times it appears again. For example, this product has the price difference: hidden link as do many other products.

July 2, 2019 at 7:33 pm #4129745

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Yes, I can see the issue now.

I would like to ask you to follow this steps:
- Edit the product in the default language -> Make a small change -> Save the changes -> Update the translation.

Does the issue persists?

Regards,
Carlos

July 2, 2019 at 8:00 pm #4129927

stefanijaV

Carlos, you're onto something here. 🙂 Now that I edited the product in original language, the price has changed to the correct one. I hope I don't have to do this to all of them though.

July 3, 2019 at 9:11 am #4133719

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

It is possible that you will have to do this for each product, however, before that I would like to ask you one more step:
- Go to Products in the default language -> Select them all -> Use the option 'Bulk Actions' at the top of the table -> Click 'Apply' button -> Click 'Save' button without making any change.
- Do the same for the secondary language.

Could you tell me the result?

Regards,
Carlos

July 3, 2019 at 9:25 am #4133897

stefanijaV

This works as well. Still not what I expected as I thought WOOBE bulk editor and WPML were supposed to work together but I guess this is the only option. Unless you have any other recommendations.

July 3, 2019 at 10:31 am #4134925

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you tell me if the plugin you used for the bulk edit appears in our list of compatible plugins? https://wpml.org/documentation/plugins-compatibility/

Regards,
Carlos

July 3, 2019 at 10:43 am #4135047

stefanijaV

Yes, right here: https://wpml.org/plugin/woobe-woocommerce-bulk-editor-professional/

July 3, 2019 at 11:01 am #4135179

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your feedback.

Then the most probable cause was an issue or a minor problem at the moment of the execution of the bulk edit.

Please let me know if the issue persists?

Regards,
Carlos