Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to: set the privacy policy in wp-admin->settings->privacy.
The same page is translated in 2 languages. If I change the language to English, and I set the privacy Policy page to the english one, then it deletes the setting for the other language.

Solution: I found that the value of the Privacy Policy page ID was saved as an admin text, so I added the following XML code in WPML -> Settings -> Custom XML Configuration tab:

<wpml-config>
    <admin-texts>
        <key name="wp_page_for_privacy_policy"></key>
    </admin-texts>
</wpml-config>

- And then translated the ID of the Privacy Policy in English with the ID of the translated page in Polish.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 25, 2020 at 3:23 pm #5992749

Sergio

I am trying to: set the privacy policy in wp-admin->settings->privacy.
The same page is translated in 2 languages. If I change the language to English, and I set the privacy Policy page to the english one, then it deletes the setting for the other language.

In short there can be only 1 language of privacy policy everywhere. But I want WPML to show the English privacy policy in the english site, and the other language in the other language site.

Link to a page where the issue can be seen: hidden link

Can you please help?

April 28, 2020 at 12:17 pm #6012279

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

I just visited the site and the privacy policy page appears correctly for both languages:
- hidden link
- hidden link

This means that the settings are applied correctly.

Kind regards,
Carlos

April 28, 2020 at 1:14 pm #6012605

Sergio

Hello, I think you are looking at the "pages" widget in the bottom left. That one is good, because pages are well translated.

However the php code of the code that is in the bottom right, near the copyright notice. That one is not working well

April 28, 2020 at 1:16 pm #6012681

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Yes, you are correct, I was looking at the wrong link.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back-up the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

April 28, 2020 at 3:51 pm #6013839

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,
Thank you very much for the information provided.

I found that the value of the Privacy Policy page ID was saved as an admin text, so I added the following XML code in WPML -> Settings -> Custom XML Configuration tab:

<wpml-config>
    <admin-texts>
        <key name="wp_page_for_privacy_policy"></key>
    </admin-texts>
</wpml-config>

- And then translated the ID of the Privacy Policy in English with the ID of the translated page in Polish.

Now the issue is solved. Could you confirm that the link is showing the correct link in each language?

Regards,
Carlos

April 28, 2020 at 6:32 pm #6014941

Sergio

My issue is resolved now. Thank you!

April 28, 2020 at 7:58 pm #6015663

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos