This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by walterR-6 1 month, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 19, 2019 at 7:33 am

walterR-6

I am trying to translate the link in the attached diagram to German but cannot find a string for it. It appears to be similar to this issue but mine is on the login page privacy text.

https://wpml.org/forums/topic/need-to-change-privacy-policy-language-link-on-checkout-page/

August 19, 2019 at 11:50 am #4415691

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there.

I have checked your site, It seems you are using an older version of WooCommerce, Please update to the latest version and check if the issue can be reproduced. As far as I see we don't have any reported issue with privacy URL transaction this should be fetched automatically by WPML.

Please secure a backup of your site and database, Before you proceed with the update.

Let me know the results.

Kind regards
Raja

August 19, 2019 at 3:30 pm #4417117

walterR-6

Hi there. Woocommerce has been updated but the issue was not fixed.

August 20, 2019 at 9:35 am #4422173

walterR-6

Hi there, any updates please?

August 20, 2019 at 10:05 am #4422457

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI, I am checking the issue on a clean installation, I will update you in a while.

August 20, 2019 at 11:34 am #4423161

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am unable to reproduce the issue on a fresh installation, Everything seems to work fine hidden link

For some reason, I am not able to access your site it keeps loading forever, could you please check the issue with your site.
- once you have access to your site, Navigate to WooCoommcer > Settings > Accounts and privacy
- Select the language as DE from the top bar language selector
- Make sure you are on the same page, in Privacy page option remove the value (keep it empty) and save the settings

Let me know the results.

August 20, 2019 at 2:38 pm #4424487

walterR-6

Hi there, so the last suggestion fixed the issue. The value was already empty on the German page so I just pointed it to the German Privacy Policy page and that resolved the issue. many thanks for your help!