This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by Dan 7 months, 2 weeks ago.

Assigned support staff: David.

Author Posts
March 4, 2019 at 6:42 pm #3270364

Dan

Hi David,

Regarding your first message, we haven't updated to 4.2 so far.

I have done a fresh copy of your production site at dev3.internetsociety.org

I have created you an admin account for david.g@onthegosystems.com
You can access that account by using the Lost password feature.

Using duplicator, can you get a database dump?

WPML plugins are updates as follows:

- Gravity Forms Multilingual: updated from 1.4.0 to 1.5.0.
- WPML Media: updated from 2.4.2 to 2.5.1.
- WPML Multilingual CMS: updated from 4.1.4 to 4.2.4.1.
- WPML String Translation: updated from 2.9.2 to 2.10.2
- WPML Translation Management: updated from 2.7.3 to 2.8.3.

- Run now for about two minutes

- executed INSERT INTO wp_options (option_name, option_value) VALUES ('wpml-tm-translation-jobs-migration', '1')

I hope that helps for troubleshooting.
Best,
Henri

March 4, 2019 at 6:44 pm #3270385

Dan

Please read "of our production site"

March 4, 2019 at 6:50 pm #3270405

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thanks, let me take a look.

March 5, 2019 at 1:33 pm #3274204

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

After updating to WPML version 4.2.4.1 everything fell into place.
Are you still seeing that second notice? The staging site seems to be behaving fine.

March 5, 2019 at 1:54 pm #3274358

Dan

Hi David,
That's strange, you didn't do anything?
I will re-sync once more and go through the whole process before doing that on production.
I will let you know how it goes.
Henri

March 5, 2019 at 2:10 pm #3274479

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Great, keep me posted.

March 5, 2019 at 3:32 pm #3274864

Dan

Hi David,

I have re-synced again the whole thing (files and db) and the error is indeed back. See the screenshot.
The difference this time is that wordpress core is now updated to 5.1. The "Run now" button seems to do his job but even when inserting wpml-tm-translation-jobs-migration as instructed earlier, it doesn't go away.

Also I created your user again: david.g@onthegosystems.com

Could you take a look again and let me know your findings?

Also, do you possibly have some chat tool? We use slack, jabber, zoom.
this would help to accelerate the debugging process.
Thanks!
Henri

March 5, 2019 at 4:17 pm #3275067

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

After going to Settings -> Redis and flushing the object cache the notice disappeared.

March 5, 2019 at 4:20 pm #3275074

Dan

Wauh good catch!
I cleared: nginx, wp cache flush, cdn, but I missed Redis
good to have 4 eyes.
Going ahead now with production and let you know the result soon.

March 5, 2019 at 4:24 pm #3275103

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

great, fingers crossed 🙂

March 5, 2019 at 4:59 pm #3275389

Dan

Hi David,
That's now deployed on our production site. It's beer o'clock! Have one for me.

The query INSERT INTO wp_options (option_name, option_value) VALUES ('wpml-tm-translation-jobs-migration', '1') followed by flushing of all different caches made the job.

With kind regards from Switzerland,
Henri