Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 23, 2017 at 7:39 pm #1283092

doreenT-2

I am trying to:
Add chinese Translations

URL of (my) website where problem appears:
hidden link

I expected to see:
Chinese Translation but the site is throwing errors (as attached) when I am trying to add new post (in any Language).

Summary of the problems I am facing are:
1. SQL Errors/Taxonomy - The SQL errors which were attached. See all of the screenshots related to SQL syntax and taxonomy. It appears to be the same issue presenting itself over and over. I went in and deactivated the code that was throwing that error, but in the background the problem still exist in the plugin.

2. Sidebars when adding Chinese translations - when we add the Chinese translation we don’t have the option to add sidebar items/text like we did in English and Spanish. Only for Chinese has this sidebar option disappeared.

See how it appears in English: hidden link

See how it is gone in Chinese: hidden link

3. Can't add images under Chinese Translations - I just tested the translation on the Innovation page and while the text carried over I can’t add the images. The actual ADD MEDIA button is gone from Chinese translations. I tried to toggle them to just copy in the multilingual content fields but then actually got the SQL error again. - > hidden link

Steps to duplicate the issue:
1. UPDATE WPML plugin to latest.
2. Adding any post, Taxonomy term will throw SQL error.

We have create logins for you on our site, so that you can debug the problem:
hidden link
Username: wpml_user
Password will be provided once you provide us the email address.

Let us know if you need additional information or access.

May 24, 2017 at 1:53 am #1283217

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello @doreent-2,

Thank you for contacting WPML support. I'd be happy to help you on this.

To debug this issue further, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

We'd like to request the permission to disable, enable and install themes and plugins for this site. Please accept this?

Look forward to your reply.

Thanks

May 29, 2017 at 3:28 pm #1286658

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

today Shekhar is not available, he will come back tomorrow and help you further on this issue.

Thank you for your patience.

May 30, 2017 at 8:14 am #1287035

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

The login details are not working for me, could you please check it.

Meanwhile could you please check if the issue occurs when following the below steps:

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

I look forward to your reply.

Thanks

May 30, 2017 at 12:12 pm #1287293

doreenT-2

Hi Shekhar,

Can you please tell me what logins are not working for you? WordPress Logins or FTP Logins?

Following is the Log file last 6 errors:
[20-Apr-2017 18:02:41 UTC] PHP Notice: Trying to get property of non-object in /home/ssicom6/ssiaeration.com/wp-content/plugins/blank-slate/blank-slate.php on line 126
[20-Apr-2017 18:22:14 UTC] PHP Strict Standards: Only variables should be passed by reference in /home/ssicom6/ssiaeration.com/wp-content/plugins/backupbuddy/destinations/dropbox/lib/dropbuddy/pear_includes/HTTP/OAuth/Signature/Common.php on line 58
[20-Apr-2017 18:22:14 UTC] PHP Strict Standards: Only variables should be passed by reference in /home/ssicom6/ssiaeration.com/wp-content/plugins/backupbuddy/destinations/dropbox/lib/dropbuddy/pear_includes/HTTP/OAuth/Signature/Common.php on line 58
[20-Apr-2017 18:22:16 UTC] PHP Strict Standards: Only variables should be passed by reference in /home/ssicom6/ssiaeration.com/wp-content/plugins/backupbuddy/destinations/dropbox/lib/dropbuddy/pear_includes/HTTP/OAuth/Signature/Common.php on line 58
[20-Apr-2017 18:22:16 UTC] PHP Strict Standards: Only variables should be passed by reference in /home/ssicom6/ssiaeration.com/wp-content/plugins/backupbuddy/destinations/dropbox/lib/dropbuddy/pear_includes/HTTP/OAuth/Signature/Common.php on line 58
[20-Apr-2017 18:22:16 UTC] PHP Strict Standards: Only variables should be passed by reference in /home/ssicom6/ssiaeration.com/wp-content/plugins/backupbuddy/destinations/dropbox/lib/dropbuddy/pear_includes/HTTP/OAuth/Signature/Common.php on line 58

May 31, 2017 at 2:10 am #1287904

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

The wp-login details are not working for me, could you please check it.

Also, could you please share the results of the minimal setup?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

May 31, 2017 at 9:35 am #1288118

doreenT-2

Hi Shekhar,

I tried disabling all the plugins and switching the theme to default Twenty sixteen but still the issue is occurring on frontend and backend.

Thanks.

June 1, 2017 at 7:17 am #1289044

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for the details

I couldn't replicate the syntax error now, is the problem solved? If not could you please provide a link where I can see this error.

Also, for the second issue, are you using this field from ACF? If so could you please go to the page Editor Multilingual content setup tab and mark that fields as translatable. When I went to Innovation page to check this I couldn't see the sidebar tabs at all, so could you please enable it so I can let you know which field to mark as copy.

Regarding the third issue, in translation editor add media option is not added yet, if you prefer to use different images and require media button, you can go to WPML->Translation Management->Multilingual Content Setup -> How to translate posts and pages and select "Create Translation Manually". Does this helps?

I look forward to your reply.

Thanks

June 2, 2017 at 8:24 pm #1290510

doreenT-2

Hi Shekhar,

Regarding your message:
"I couldn't replicate the syntax error now, is the problem solved? If not could you please provide a link where I can see this error."

I disabled the warning by tweaking the code inside sitepress-multilingual-cms plugin folder. So what I did is now, I download a fresh copy of plugin from Downloads section and uploaded to the site. Once I uploaded the plugin files.

It is throwing the following errors on site:

Warning: include(/var/www/html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/../../classes/hooks/adjacent-links/class-wpml-adjacent-links-hooks-factory.php): failed to open stream: Permission denied in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

Warning: include(): Failed opening '/var/www/html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/../../classes/hooks/adjacent-links/class-wpml-adjacent-links-hooks-factory.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

Warning: class_implements(): Class WPML_Adjacent_Links_Hooks_Factory does not exist and could not be loaded in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php on line 16

Warning: in_array() expects parameter 2 to be array, boolean given in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php on line 18

Warning: in_array() expects parameter 2 to be array, boolean given in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php on line 19

Warning: in_array() expects parameter 2 to be array, boolean given in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php on line 20

Warning: include(/var/www/html/wp-content/plugins/wpml-string-translation/classes/wpml-string-shortcode.php): failed to open stream: Permission denied in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

Warning: include(): Failed opening '/var/www/html/wp-content/plugins/wpml-string-translation/vendor/composer/../../classes/wpml-string-shortcode.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

Fatal error: Class 'WPML_String_Shortcode' not found in /var/www/html/wp-content/plugins/wpml-string-translation/inc/wpml-string-translation.class.php on line 89

Can you check into this why the newer version is throwing more errors? May it is connected with the problems we have with Chinese Translations?

Thanks.

June 5, 2017 at 1:50 pm #1291350

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I am able to see the issue on your site and to debug this issue further, I would need to replicate your site on my localhost and perform further debug.

Could you please send me wp-content backup and database backup so I can clone your site on my localhost? This is required since I am not able to replicate the issue on my fresh installation. You can upload those file on google drive and share the links with me.

I have enabled the private reply for you.

Look forward to your reply.

Thanks

June 6, 2017 at 9:56 am #1292042

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I am working on this issue and will respond to you soon.

Thanks

June 7, 2017 at 5:31 am #1292743

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I replicated your site on my localhost and performed further debugging. And when I install a fresh new copy of WPML from the downloads section the issue is solved for me.

As you already mentioned that you have already done this and the issue is still there, will it be ok that if I try to install a fresh copy of WPML on your site. Please create a backup first and let me know if that is Ok.

Let me know your thoughts on this.

Thanks

June 7, 2017 at 8:48 am #1292889

doreenT-2

Hi Shekhar,

The site is backed up. Yes Please go ahead.

Thanks.

June 7, 2017 at 9:08 am #1292905

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Your ftp details is not working, could you please check it once? Currently, the ftp detail is showing just a file on your server.

Look forward to your reply.

Thanks

June 7, 2017 at 10:14 pm #1293499

doreenT-2

Hi Shekhar,

You need to move to this folder path on your FTP, once you are logged in:
/var/www/html

(see screenshot attached)