Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: How can I get the attributes to show in the correct language when editing a product?

Solution: In this case the attributes were added in Greek, but assigned to the Greek language. To resolve this, go to WPML -> String Translation and change the language of the strings to Greek. Then you can add the English translations.

Alternately, you could edit the original attributes and add the Greek translations via WooCommerce -> WooCommerce Multilingual -> Attributes.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by The Smalls 3 years, 1 month ago.

Assigned support staff: Lauren.

Author Posts
January 23, 2018 at 10:09 am #1493358

The Smalls

Tell us what you are trying to do?
Hi, i have 2 languages, greek and english (greek was the 1st language and english is on going translation).
The admin that inserts products is using the greek admin interface and cant understand english (another user is then translating the products).

So, when he adds a product he clicks attributes, selects the attributes from the list, adds them and then sets the values.

As you can see in the attached picture, i've translated only the "origin" to english and in the dropdown is in english. After adding it it displays the greek translation, but if i translate all the attributes the user will not be able to add the attributes because cant understant what is what in the select box (before adding them).

Is there a way to display the greek attribute name in the select box?

Best regards,

As you can see in the attached photo (screenshot of product details) there are 6 attributes and translated only one (origin). I didnt translated it all, as the user will not understand what is what.
At the bottom you will see that after adding the "origin" attribute it displays the greek translation "προελευση"

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
The problem is on the admin only, front-end etc are working as expected

January 24, 2018 at 12:09 am #1494699

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If I understand correctly, when you translate the attributes to English, the English version displays in the drop down instead of the Greek version. Is that correct? If so, to best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

January 26, 2018 at 3:03 pm #1498371

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending the files, I was able to set up a copy of your site. I found that as long as I create the atrributes in Greek, then the correct names will display. The problem you are seeing comes from when you create the attributes original name in English. For example, I created an attributes "δοκιμή" and translated it to English "test". You can see in the screenshot that the Greek attribute label still shows correctly even after it has been translated.

I also created an attribute "Test Two" and translated it to Greek. Since I created it in English and the default language is set to Greek, the English name "Test Two" is showing in the product attribute drop down.

So in summary, as long as you create the attribute original name in Greek, it should display correctly. Please let me know if you need any further assistance and I will be happy to help.

January 26, 2018 at 3:14 pm #1498384

The Smalls

Hi, thank you for your efforts.
I first installed the site in greek, then added wpml and when asked in which language is the current data in initial wpml setup i set greek. I have hundrends of products and i cant delete and re-create the attributes. What i can do now?
Best regards,

January 26, 2018 at 3:31 pm #1498411

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

You can edit the existing attributes. Go to Products -> Attributes and you will see a list of all attributes. Under Origin, click Edit and change the name and slug. I did this on my test site, and now you can see in the screenshot that "Origin" has been replaced by "προέλευση".

Please let me know if this solution works for you. Thanks!

January 26, 2018 at 3:43 pm #1498436

The Smalls

Thank you very much. I forgot that i can switch the language in the string translation, so i set greek as the default and translated the english text.
Best regards,