This thread is resolved. Here is a description of the problem and solution.

Problem: I expected to see the checkout page to recharge the amount needed. Instead, in 2nd language, I get the shopping cart page stating that the cart is empty.

Solution: Please follow the next steps and image attached:

- Go to WooCommerce Multilingual > Products > Wallet Topup - Click Edit - While on default language Edit product screen, use language switcher on top to switch to Translations of these products - While on the Translated product Edit screen, click on "Move to trash". It is located on the right side inside the Publish box. - Be sure to delete all translation for Wallet Topup products. You should have only + icon, meaning there are translations for this product. (Screenshot 4) - Go to WooCommerce > Products > Trash > All languages > Click "Empty trash" button located at the bottom of the page. - Go to WPML > Settings > Post Types Translation > Product - Set Products > "Translatable - use translation if available or fallback to the default language"

You should now be able to add top-up wallet in all languages, be aware it requires Product to be set "fallback to the default language".

Relevant Documentation: - https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 4 voices.

Last updated by tamerm 2 weeks, 5 days ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
May 30, 2020 at 9:02 pm #6257315

tamerm

I am trying to: recharge terawallet plugin in arabic
Link to a page where the issue can be seen:
hidden link
I expected to see:
i expected to see the checkout page to recharge the amount needed.
Instead, I got:i got the shopping cart page stating that the cart is empty.

June 1, 2020 at 1:18 pm #6265735

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

Can you tell if you made these settings like this?

If yes, can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme

Regards,
Bruno Kos

June 1, 2020 at 6:45 pm #6268077

tamerm

Hello,
actually its working on the Arabic language on a staging website but the only difference between the staging website and the live website is that the live website is using friendly url and the staging website is using the plain query url like souq/?page_id=1464&woo-wallet=add.
and its working fine in the live website using the English language so i think this is related to the arabic url type only.
Best Regards,
Tamer Maleh

June 2, 2020 at 6:31 am #6270395

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I would say this is expected.

You are using Different languages in directories option.

As mentioned in our documentation, for this to work the site needs to use a ‘fancy’ permalink structure (e.g., anything different than the default permalinks).

Info: https://wpml.org/faq/server-setting-for-languages-in-directories/

Please check and let me know if I understood something wrongly.

Thanks and regards,
Drazen

June 2, 2020 at 4:49 pm #6276357

tamerm

Hello,
The live website settings is using' Different languages in directories' and its using a fancy permalink not the default but its not working with this plugin only in the arabic language, so i am not sure what might be causing this.

June 3, 2020 at 6:50 am #6279929

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

1) Please share steps on how I can see the issue once I logged in.

2) In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Thanks and regards,
Drazen

June 3, 2020 at 9:43 pm #6287677

tamerm

Hello,
can you support a testing cloud for this test because this website is live and i have alot of vendors adding and updating products daily , so it is a little hard for me to test on the live website?

June 5, 2020 at 9:30 pm #6308571

tamerm

I got migration failed and tried again , and same result migration failed, i am not sure what is the issue here?
also the author replied to my question about the issue and he said "Our plugin is not WPML supported yet. Will try to fix this issue on our next update".

incase you managed to make the testing cloud work, here are the steps:
-when you login in, go to manage your orders section to manage the clients dashboard , you can see it when you click on the username in the home page.
-then click on my wallet.
-you will see a button called wallet topup , after you click it you will see a page that have a field and a button and the amount that should be added to the wallet , if you are opening the english version , this will be treated as an order and you will be redirected to the checkout page.
if you want to regenerate the issue then while you are in the topup page before adding the balance , choose the arabic language, and then add the balance in the amount field and click the add button, the page will be redirected to the cart page and it will contain a message stating that there are no products to continue.

June 6, 2020 at 1:30 pm #6311313

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I see the author updated you the plugin is not compatible with WPML and they will try to fix the issue in the next version. That being the case I am not sure we can do much on our side.

I am providing you with a clean sandbox and kindly ask you to recreate the issue.

Then I can forward this issue to our compatibility team to check if there is anything we can do on our side or we will have to wait for the author to update the plugin.

Please try to use only the necessary theme/plugins.

Sandbox link: hidden link

Let me know how it goes.

Thanks,
Drazen

June 6, 2020 at 8:31 pm #6312627

tamerm

Hello,
the issue doesn't happen on the sandbox , i used only the new woocommerce with wpml and the default theme, so now i am really not sure whats going on? could be a server setting or another plugin ? how can detect this , i tried the debug mode on the live website and downloaded the error log but i couldn't see an error that is related to the wallet page?

June 6, 2020 at 9:05 pm #6312635

tamerm

Hello,
i regenerated the issue , i installed a copy of the theme i am using on the live website (rehub theme) and the issue happened when i tried to add money through the topup in the arabic language, please follow the following steps in the sandbox:
-go to this page الحساب الشخصى while selecting the arabic language.
- click on My Wallet
- click on wallet topup
- add the value in the amount field.
- after you click the add button you will see a notice in the arabic language in the cart page stating that the cart is empty, and it should go to the checkout page, you can see the difference if you choose the english language.

June 8, 2020 at 11:31 am #6320353

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for sharing info.

I was also able to reproduce the issue and it seems it is working only on default language, Wallet top-up is not working in any 2nd language.

I will be escalating this ticket to our Compatibility team to see if there is anything we can do on our side to help you out with this issue.

Otherwise, as the plugin author informed you their plugin is not compatible with WPML we might need to wait for the plugin author to check and provide a solution.

It would be good if you could invite them to our Go global program. WPML’s Go-Global helps turn WordPress plugins into fully multilingual-ready.

- https://wpml.org/documentation/theme-compatibility/go-global-program/

I will update you as soon as I have some news about this issue.

Thanks,
Drazen

June 8, 2020 at 1:08 pm #6321373

tamerm

Hello,
ok thank you but i would like to note that the issue appeared in the sandbox after i added the live theme i have on the website ,i uploaded it on your demo, and when i tried with the default wordpress theme the issue was gone,so i am think it might be an issue with the theme and the plugin too, but i just thought you should try that too.

June 8, 2020 at 2:14 pm #6322271

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the reply.

Yes, I noticed, then I went and replicate the issue on a clean install with only WPML plugins and using the WP default theme. Using English as default and Italian as second language.

The issue was still there.

I have tried changing product visibility, translating, duplicating and some other quick fixes I could think, but nothing helped. The issue was still there.

That is why I escalated to see if our compatibility team can help.

I will update you once I get an update from them.

Thanks,
Drazen

June 11, 2020 at 2:36 pm #6352077

tamerm

Hello,
is there any update from the team about the issue?