This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by ericJ-2 1 year, 4 months ago.

Assigned support staff: Bruno.

Author Posts
May 14, 2018 at 4:51 pm #2124828

ericJ-2

Hello wpml. I first created a bilingual website english/brazilian portuguese. In that time you guys supported me helping installing it, because I was having some issues. No I am trying to install chinese language, but it is not properly working in chinese: links not working and page not loading. My site is hidden link
I need your help to make it work in chinese please.

Thank you so much in advance!

May 15, 2018 at 4:15 pm #2144223

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us.

From what I've noticed, this is happening because you are translating the section IDs. This is causing a script error. I'll attach an image for you to see.

Please, could you access the homepage Chinese translation and change the name of these sections IDs to English or Portuguese (without accent) to test?

Note: se você preferir o suporte em Português, por favor, deixe-me saber.

Thank you.

May 15, 2018 at 5:57 pm #2145797

ericJ-2

Hi Bruno, thank you so much for your help.

I am not a programmer, sorry, and I don't know how to change sections IDs. I am editing using wordpress content manager. Where can I change this ID? You mean change menu's link names? (img attached)

May 15, 2018 at 6:13 pm #2146076

ericJ-2

I Changed menu names and still doesn't work

May 16, 2018 at 1:35 am #2148962

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

This content should actually be inside the homepage. Inside the homepage, you must have included modules and within these modules must have IDs.

According to your theme, you should be using Visual Composer, correct? Please, for you to try to locate these IDs, go to the homepage in the original language and click to edit this page.

Open one of these modules and see if you find any options such as "Section ID" or "Element ID". If yes, see what you are using in the field of this option. Then click to edit the Chinese translation and see if that content is translated. If so, just edit this and keep it in English.

After following these steps, please let me know if the problem persists. If the problem persists, I will request the credentials.

Thank you.

May 16, 2018 at 11:39 am #2155986

ericJ-2

Thank you so much Bruno, ow seems to work perfectly.

But I still have another little problem, maybe you can help me. On the top of chinese page, over the photos, there is a white space I cannot delete it. (image bellow). Do you know how to fix it?

Thank you in advance

May 16, 2018 at 7:54 pm #2163614

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'm glad this worked. 🙂

On white space, this looks like it has some module (maybe a space module) in the Chinese translation.

Please follow the steps below to verify this:

- Open the home page on the default language
- Click to edit the homepage
- Switch to the Chinese page using the top bar
- On the Visual Composer, see if there is any module that is creating this space.
- If so, remove this space and save your changes.

Also, you can see if this empty module is added in the primary language. Maybe this is added, but it is not visible. If it is added, remove the empty module from the primary language and save the changes. Then, go to the Chinese translation page and click on the "Save & Close" button

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

May 22, 2018 at 1:17 pm #2208429

ericJ-2

Thank you Bruno. The problem for the white bar wasn't solved, but is ok. Thank you for your support and fast answering.