This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by michaelP-72 3 weeks, 2 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 18, 2019 at 3:38 pm #4598241

michaelP-72

Good evening,
I can't translate the Reserved Area section of the site into the languages: French, English and German.
I tried going to the section: Translation strings,
but I found nothing.
How is it possible?

Thank you is urgent and greetings.

Michael

September 19, 2019 at 12:54 pm #4604905

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Have you looked into the admin texts?

Please visit this link where you will find the steps to translate admin texts: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

September 19, 2019 at 1:27 pm #4605197

michaelP-72

Hello and thank you for your kind reply.
1) I have reviewed but I can't do it if I give you the website access codes?
2) Here is the bug:

Greetings, Michael

September 20, 2019 at 9:57 am #4611173

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Michael,

1.- Please attach some screenshots to your next answer and highlight the texts you need to translate. This way I will be able to locate them easily.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

September 20, 2019 at 10:31 am #4611465

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

Could you explain what do you mean by: "when I change the language, I can't get the site to work automatically."

Regards,
Carlos

September 20, 2019 at 10:34 am #4611469

michaelP-72

It's simple to understand.
Now on the site if you go to see and go on LOGIN you always stay in ITALIAN language and even at the language change you always stay on ITALIAN and so it doesn't have to be and is not functional.

September 20, 2019 at 11:03 am #4611611

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

When I visit the site I can switch languages in the frontend correctly. To switch the language in the backend you need to edit your profile page and set the admin language.

Could you describe what do you expect to happen in the site when an user visit it? What would be the perfect scenario?

Regards,
Carlos

September 20, 2019 at 12:45 pm #4612213

michaelP-72

Sorry but I don't speak another language and I don't have time to waste with these answers.
I am in Italian: hidden link and now I go to LOGIN: hidden link but I am always in Italian.
While if I go to German: hidden link and now I go to LOGIN: hidden link, the url address does not change and I'm always in ITALIAN and it's not correct.
I want to automatically change the URL outside the website and then backend.
Now do you understand?

September 20, 2019 at 12:59 pm #4612373

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Now I understand.

This behavior is correct as the backend language is not defined by the URL you log in, but it's defined in the profile page of your user (as I mentioned in my previous message). To set this admin language you need to edit your profile -> Set the language you desire for the backend and you can also activate the option of switching languages depending on the backend language (see attached image).

Regards,
Carlos

September 20, 2019 at 1:19 pm #4612637

michaelP-72

Nothing works nothing.
I'm always in Italian and I can't get the correct login page for the other languages and translated.
My question is: can it be done or not ???

September 20, 2019 at 1:44 pm #4612791

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

As I mentioned before, the language of the backend is set in the profile page of the users and is a WordPress feature, not a WPML feature. Please edit the profile page of the user, apply the changes described in my previous message and confirm that the language switches according to the configuration you set in the profile page.

Regards,
Carlos

September 20, 2019 at 1:51 pm #4612811

michaelP-72

I do not understand...
Can you do it please ???

September 20, 2019 at 2:30 pm #4613013

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just added the configuration in your profile page, now when you log in and switch languages in the backend, the backend language will change too.

Regards,
Carlos

September 20, 2019 at 2:47 pm #4613053

michaelP-72

Nothing works ...
I still see when I log in to English, French and German the translation into Italian and also the url ...

September 20, 2019 at 2:52 pm #4613065

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

After login you will be always be redirected to /wp-admin which is the backend and the language that appears by default will be the one selected in your profile page. You can now switch the language in the backend and all the language will change. This is the correct behavior.

If your goal is to make the backend been show in the same language as the login page then you will need custom code which falls outside of our scope as a support service. In this case I would recommend you to contact one of our certified partners in this link: https://wpml.org/contractors/

Thank you very much for your understanding!
Best regards,
Carlos