This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

An Uncode theme issue. The header logo's ID could not be found in the Strings Translation fro translation, and therefore another logo image for the other language could not be placed.
Solution:

It is also possible to register those strings in the Custom XML Configuration section. You can get there here WPML -> Settings -> Custom XML Configuration (tab). I've added those fields there.

<wpml-config>
<admin-texts>
    <key name="uncode">
     <key name="_uncode_logo_light" />
    </key>
</admin-texts>
</wpml-config>

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 11 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
October 15, 2018 at 9:01 am

sarie

Hi,
I have a Unicode theme (themeforest.net) and there in the site should be possible to change header logo in String translation page. But I can't find logo with ID number - there is not that. So I can't change logo in header. And now the theme author asked me to ask you.

The problem is that WPML is not reading the modification. The theme author got another user with the same problem time ago.

They suggestion is to contact WPML support and ask how can I refresh the "wpml-config.xml" so that I can see the updated option.

Kind regards
Sari

October 16, 2018 at 4:14 pm #2821769

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've searched hidden link for the Unicode theme but couldn't find it.
I've also searched on our site here https://wpml.org/documentation/theme-compatibility, and I do not see that this theme is compatible with WPML.
Can you please send me the link to this theme?

Also could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

October 17, 2018 at 7:01 am #2823383

sarie

Hi
Here is a link what about my problem
hidden link
So I can't find the ID where to change logo to the other language. Media translation I have a both logos Finnish language and English language.

Theme Uncode
hidden link

Kind regards
Sari

October 17, 2018 at 6:45 pm #2825666

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Sari and thanks for the extra details.

The Uncode theme is compatible with WPML.
https://wpml.org/documentation/theme-compatibility/build-multilingual-wordpress-websites-using-uncode-theme-and-wpml/

I could find those logo strings in the admin strings screen, but I could not make them show in the Strings Translation section. This is a limitation that is sometimes happening when you have too many admin strings, and the max_var value of your server is low (MaxInputVars is 5000 on your server). You can read more about the translating strings from themes and plugins options at the following link.
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Luckily, it is also possible to register those strings in the Custom XML Configuration section. You can get there here WPML -> Settings -> Custom XML Configuration (tab). I've added those fields there. Please see the attached screenshot register-admin-text.jpg. And now the logo IDs are available for translation in the Strings Translation section. Please see the attached screenshot uncode-log-st.jpg

Please let me know if now you can translate the logo ID?

Regards,
Itamar.

October 19, 2018 at 12:24 pm #2831963

sarie

My issue is resolved now. Thank you!

October 21, 2018 at 9:49 am #2835375

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.