Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Mihai Apetrei 8 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 12, 2019 at 2:56 pm #3323863

pabloR-21

I am trying to: translate libraries from oceanWP theme, I am able to translate libraries, and translate footer string (see attached img). Even do, I can't translate header strings and in the translated page, footer is not translated

I did this things before: https://wpml.org/forums/topic/custom-header-in-oceanwp-using-elementor-translation-doesnt-display/

Link to a page where the issue can be seen: hidden link

March 12, 2019 at 5:17 pm #3326927

pabloR-21

To have a quick solution, I MANUALY change the header and footer style of the page editing. But I STILL need a solution to fix the problem. Because I CAN'T see custom headers strings.

March 13, 2019 at 11:59 am #3332725

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see, it seems that the issue that you are experiencing is similar to this one in the link below:
https://wpml.org/forums/topic/custom-header-in-oceanwp-using-elementor-translation-doesnt-display

If following those steps don't solve the issue, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 14, 2019 at 10:31 am #3342923

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

Thank you for the confirmation and for the credentials!

I can confirm that they work.

From what I can see (I will also attach screenshots), the footer works in both languages so I think that you are seeing a cached version of your homepage. Can you please try visiting these two pages from an incognito browser window or from a new browser that you never used to load the site before:

hidden link
hidden link

Also, the settings on your server should be changed so that they can follow the WPML minimum-requirements listed here:
https://wpml.org/home/minimum-requirements/

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. We need to increase the MaxInputVars to 15500 - currently, you have them set at 1000.

For this, please try to set this variables in your php.ini:

max_input_vars = 15500;
suhosin.post.max_vars = 15500;
suhosin.request.max_vars = 15500;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 14, 2019 at 2:10 pm #3345273

pabloR-21

Hi Mihai, I'll try what you said. Regarding the footer, as I said in my previous answer:

"To have a quick solution, I MANUALLY change the header and footer style of the page editing. But I STILL need a solution to fix the problem. Because I CAN'T see custom headers strings."

It DOESN'T works, I change it MANUALLY and not using WPML. This is what I see know with normal settings

March 14, 2019 at 2:34 pm #3345625

pabloR-21

Hi Mihai, thanks for your answer, but I did this changes and everything is the same. I can't activate any string regarding custom header

March 14, 2019 at 3:03 pm #3346053

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

Thank you for the extra information.

1. So, first of all, from what I can see, the WP memory hasn't been changed yet - it is still 40M.

Can you please take care of that first?

2. After that is done, can you please leave the footer in the state where it DOES NOT work for a couple of minutes?

3. Can you also explain the exact steps you are taking to make the footer work like it is now? I mean how do you do this: "I MANUALLY change the header and footer style of the page editing." ?

4. Can you also explain a bit what you mean by saying "I CAN'T see custom headers strings." ? Can you create a screenshot and write over it or put some arrows explaining what you would expect to see and where?

Thank you very much for your patience and for helping me better understand what you want to accomplish.

I will be waiting for your response!

Kind regards,
Mihai

March 14, 2019 at 3:15 pm #3346145

pabloR-21

1. Sorry. My Fault. Could you please check again

2. For me know it doesn't works know.

3. I go to pages > English pages > Edit > And I change the footer to the English version

4. As you can see in the image, in the admin_texts_theme_mods_oceanwp I only have 1 string (footer) but any one concerning headers. And both of them are parts of the OceanWP Library

Kind regards,
Pablo

March 15, 2019 at 1:35 pm #3354295

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi Pablo!

1. The memory limit is still the same. You can check it here (hidden link) after each time you try to edit that - you might need to get in contact with the hosting team if you can't increase that just by following the steps I mentioned.

2. Regarding the admin fields missing: first of all, I think we need to change our concentration to this "theme_mods_oceanwp-child-theme-master" as this is the right "Dominio" to look for taking into consideration that you are using the child theme, not the main theme.

I am attaching a screenshot with that, too.

Now:

- go to WPML > Traducción de cadenas > Traducir los textos de las pantallas de administración
- search for "theme_mods_oceanwp-child-theme-master" on the page and click on it to open it

You will see there are a good amount of elements there.

I practically searched for "ocean" on the page and I could find a lot of them.

Can you please let me know if anything there is looking like what you are searching for?

If you find what you need, you should be able to check the box next to it and then go to the bottom of the page and save it.

Please let me know how that goes!

I will be waiting for your response.

Kind regards,
Mihai

March 21, 2019 at 6:31 pm #3417165

pabloR-21

Hi, problem with memory limit is solved (1)

Even do I can't translate headers and footers, and I am only able to translate some strings from the OceanWP library. As you can see on (2), I have 5 post on the OceanWP library. But on (3) you see that I am only able to translate 2.

Even if I search with the post ID on the string translation (4) I have any result.

I tried to search on 'Translate texts in admin screens' but with the same result (5) There is nothing regarding the other 3 oceanwp library posts

March 22, 2019 at 2:49 pm #3441507

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi Pablo.

Thank you so much for the valuable information and feedback.

I think it's becoming more and more obvious that we might be dealing with a compatibility issue.

The next step that we will need to take is to replicate the issue on a clean sandbox (testing environment) on our servers and if the issue is happening there, too, then I can forward this issue to our compatibility developers department.

I created this sandbox for you here (one-click login):
hidden link

I also set up WPML with the same languages that you already had set up on your site.

All I would need you to do is just install the oceanwp theme + the child (also, it might worth a try to see if anything changes if you try oceanwp - the main theme, not the child).

However, the main idea of a clean setup sandbox environment is to have a few plugins and themes installed as possible, only just we need to recreate the issue needs to be there.

So please let me know when that's ready and if you can replicate the issue, then we can forward this to the Compatibility department.

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

March 22, 2019 at 3:34 pm #3441939

pabloR-21

Done. I installed the plugin OceanEXTRA which is the one who creates the Lbrary. Created ant translated 3 templates on the library and 1 post (1). Check the "translate option" for libraries (2) but I think it doesn't work (3).

March 25, 2019 at 12:47 pm #3453557

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Thank you for the update.

I will take a look and if the issue is repeating, I will forward this to the 2nd tier.

I will keep you updated on the status.

Kind regards,
Mihai

March 26, 2019 at 2:51 pm #3463731

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

Thank you for your patience.

So, as far as I could test, the admin_text fields (that the developers wrote here (hidden link) that should appear don't even appear on the test site.

That post they have there is really old (November 2, 2017) and I guess it's not accurate anymore.

If you installed everything that was needed, then it means we might be looking at a compatibility issue and the only way to translate content is by creating different translations and use different shortcode.

What I mean is that I was able to simply use a different shortcode (the shortcode of the translated "Library" element called "Test 3 ORIGINAL LANGUAGE ENGLISH"). So instead of using the original shortcode "[oceanwp_library id="18"]", in the translated page I used "[oceanwp_library id="19"]".

You can see it working here:

- hidden link
- hidden link

So, in your case, you would simply need to create a normal translation of the header and footer (if those are the elements you want to translate) and use the different shortcode for each of them. This way, you can translate the strings straight into the My Library Template Builder.

Can you please tell me if that would fit your needs?

I will be waiting for an answer from you.

Kind regards,
Mihai

March 28, 2019 at 3:55 pm #3483435

pabloR-21

This is a manual solution and I will need to do it in every new post.

I prefer to solve the real problem if it is posible.