Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by ioannaC 5 years ago.

Assigned support staff: Lauren.

Author Posts
January 10, 2017 at 8:48 am #1178217

ioannaC

I am trying to:

Translate my website from English to Greek and Russian but the other day my translation desapear. I had done this 3 times. Also my menu structure always mess with these changes.

URL of (my) website where problem appears: hidden link

I will waiting for your answer.
Thank you Anna

15966712_10210886739660756_708977273_o.png
January 10, 2017 at 3:41 pm #1178704

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

How are you translating the content? Are you translating the content within a page? If so, are you using a page builder? Or are you using String Translation?

I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. Does this resolve the issue?

January 11, 2017 at 10:14 am #1179332

ioannaC

Hello Lauren,
I am using page builder (Visual Composer). I try all these that you told me but i still have the problem.

January 11, 2017 at 6:18 pm #1179911

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I would like to make a snapshot of your site so that I can try to reproduce this issue on a local copy of your website.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

January 12, 2017 at 8:03 pm #1181088

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

When I view your site, at this page hidden link, the copy is showing as translated. Did you recently re-do the translation? Please see attached screenshot.

Pelase disable your caching plugins and any server caching. Then, please let me know if the content is correctly showing the translations. If not, can you tell me if you are taking any specific action before you see the content display untranslated again?

January 24, 2017 at 11:57 am #1189253

ioannaC

Hey Lauren and i'm sorry for late reply.
Okay i think that the problem is because i do some of my changes from page builder and not from String Translation. There are anything details that i have to do?
Also, i need your help for the language switcher . The spaces between the flags are to big. Css dosen't fix that for all pages and as i read (here: https://wpml.org/documentation/getting-started-guide/language-setup/designing-custom-language-switchers-using-template-files/ ), this is one of the ways that i can do for?
This way is little difficult for me.

Thank you in advance.

Untitled.jpg
January 24, 2017 at 8:03 pm #1189822

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for the additional information. To translate the page builder content, please follow these steps: https://wpml.org/documentation/translating-your-contents/page-builders/

As for the issue with the language switcher, because this is unrelated to the original issue, may I kindly ask you please to open a new ticket for this question? This will help other users with similar problems find solutions when searching the forum as well as avoid mixing lots of questions in one ticket.

Thank you for your understanding.

January 25, 2017 at 8:10 am #1190107

ioannaC

Thank you Lauren