This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Yvette 1 month ago.

Assigned support staff: Yvette.

Author Posts
May 27, 2020 at 6:35 pm #6232135


we encountered a problem with the plugin in the administrative area, when you go on changing the theme options or changing the pages. we have activated in wpml the option "A different domain for each language" and the problem occurs when we access, for example, as seen in the photo, in the template options via the site domain .de ... instead the problem does not appear if we go to the other sections of the site through the .de domain ... instead through the .it domain (the default one of wpml) it works well everywhere even on the template options or in the modification of any page ... in our opinion the problem could be given by the compatibility of the template with wpml in "A different domain for each language" mode ....
through the browser debugger, causes error 404 in the administrative area when loading files from the .de domain and located in the template folder

May 29, 2020 at 11:49 am #6249197

Bruno Kos

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)


Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

hidden link

Can I ask the you the following:
- install your theme or a plugin into the above site
- add these values into hosts file (hidden link)

- check if the same issue is happening there as well (are the template options broken as well)

That might give us some answers, whether this is indeed up to domain per language options, your server config/cache/plugin conflict or something else.

Bruno Kos

May 29, 2020 at 4:06 pm #6251383


Hi, thanks for response,
based on ! found a bug: the problem solved by disable page cache in W3 Total Cache plugin...
If I disable this option in plugin, the problem solved and when I change the language in admin area, the website remain in the same default domain, instead with page cache enabled the domain change in admin area based on chosen flag....

the only problem left is that by disabling the page cache, it is also disabled on the frontend pages of the site ... there is the possibility of applying a correction to instead leave the page enabled and remain on the default domain even by changing the language in the administrative area so as to solve the previous problem?

May 29, 2020 at 6:56 pm #6252307


there is another bug by disabling page cache: the url domain ok and remain with default domain ".it", instead the files of template in page mode editor in another language not charge js files

May 31, 2020 at 12:52 pm #6259881


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)


I will be helping you now. I understand that you have identified the original issue to be resolved / related to the W3 Total Cache plugin.

Could you please confirm that you have set the following option:
WPMl > Languages > Language URL format > Auto sign-in and sign-out users from all domains

as well as
WPML > Languages > Language filtering for AJAX operations

Then, please write back with steps to replicate the error you are describing in your last message as it is not clear what the issue is.


June 3, 2020 at 6:42 am #6279905


I confirm I have used Auto sign-in and sign-out and Language filtering for AJAX operations....
Status update:
The problem is partial solved disabled pachebcache, becouse if I change the language in administration area the problem not compare and the site remain in default domain .It, instead I change the language in front end the url domain change to the language choised but if I go in the administration area the url not switch to default language and the problem recursLanguage filtering for AJAX operations

June 3, 2020 at 8:09 am #6280647


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)


In the backend, if you manually change the URL to the other domain - what happens?

e.g. you are in the default .it domain in the backend
- you change to .en
- the backend URL remain in .it
- you now type in the correct domain .....en/wp-admin/
- does the URL change and stay in the "en" domain?

Are you able to login to the other domains?
for example: hidden link
and hidden link

And have the URL stay in the same domain as the one you logged into?

June 3, 2020 at 8:59 am #6281099


If I change in backend the domain to or .de in backend, the url not remain in .it.
If I go to hidden link, it redirect to hidden link and after login the url remain .it (hidden link)...
now if I change the flag to German, remain in .it

June 3, 2020 at 2:12 pm #6284589


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - like I said, this might be related to your issue.

Now - for the real issue. I understand that you are not able to see a backend configuration screen/template for theme options in DE.

You should be able to translate these values if they are registered in the String Translaiton table without changing to the other domain as per this article:

In this way, if the theme is written in a manner compatible with WPML, you should be able to apply the same theme options in all languages after they are translated in the String Tranlsation table.

Please try this and if you are still having issues write back with the following:
- access to your site in the private area I am opening
- navigation steps to get to the Theme options that you need to translate to DE
- URL of the fontend where I can see these theme options applied...or some other screen where I can see if the options are present in DE or not.


The topic ‘[Closed] problem with a template and different domain for each language’ is closed to new replies.