This thread is resolved. Here is a description of the problem and solution.

Problem:
When i go to : wpml->string translation->Translate texts in admin screens and select an option of the theme and click apply, i cannot then find it in string translation.

When i go again to wpml->string translation->Translate texts in admin screens i still see the option unchecked.

Solution:
You need to register this string using WPML-config XML code. You can add the XML code on WPML > Settings > Custom XML Configuration.

In this case, the client needed to register the string located in organics_options->contact_info. So we registered it using this XML code:

<wpml-config> 
  <admin-texts>
    <key name="organics_options">
      <key name="contact_info"/>
    </key>
  </admin-texts>
</wpml-config>

You can read more about the WPML XML config here: https://wpml.org/documentation/support/language-configuration-files/

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 1 year, 11 months ago.

Assigned support staff: Diego Pereira.

Author Posts
July 18, 2018 at 3:00 pm

The Smalls

hi, when i go to : wpml->string translation->Translate texts in admin screens and select an option of the theme and click apply, i cannot then find it in string translation.
When i go again to wpml->string translation->Translate texts in admin screens i see the option unchecked

my theme is organics and the option i'm trying to translate is :
organics_options->contact_info (value : Ορθοκυτταρικά Συμπληρώματα Διατροφής)

best regards,

July 19, 2018 at 1:16 pm #2534826

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please add this XML code snippet to WPML > Settings > Custom XML Configuration:

<wpml-config> 
  <admin-texts>
    <key name="organics_options">
      <key name="contact_info"/>
    </key>
  </admin-texts>
</wpml-config>

Now the string should be displayed on the String Translator.

Documentation link: https://wpml.org/documentation/support/language-configuration-files/

Please let me know if it worked for you.

Regards,
Diego

July 19, 2018 at 1:24 pm #2534836

The Smalls

that worked.
best regards,

July 19, 2018 at 1:26 pm #2534841

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved ?

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego