Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 3 voices.

Last updated by Bigul 1 week, 5 days ago.

Assigned support staff: Bigul.

Author Posts
September 14, 2020 at 9:09 pm #7013171

georgeP-29

Hi

at my site hidden link when i am trying to add products with add to cart button from catalog page, the cart is not updating correctly. I am adding 1 product then the second and every time is deleting the previous product.

Check video : hidden link

I check via site health and this is happening when i am enabling woocommerce multilingual

Please help this is very annoying for the customers

September 15, 2020 at 8:43 am #7015895

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

Would you mind updating WPML plugins to the latest versions before we resume checking this out?

Regards,
Bruno Kos

September 15, 2020 at 9:04 am #7016165
georgeP-29

Hi Bruno

Ok updated. I have also an other problem. Every time that i am doing any update to my wordpress. WPML ask me to register again. Maybe that's why was not updated.

Btw cart problem is persist after the update.

Thanks

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/every-time-i-update-to-my-wordpress-wpml-ask-to-register-again/

September 15, 2020 at 7:34 pm #7020915

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Just to make sure, the issue is existing while adding the product to the cart as a Guest User? Because I am not able to reproduce the issue exactly now. Please check the attached image for more details. Or the issue is only happening while adding products from a particular category.

Please try the following step and check is there any difference in the result.

1) Go to WPML>>Languages settings page
2) Scroll down to *Language filtering for AJAX operations* section
3) Choose *Store a language cookie to support language filtering for AJAX* option and save changes
4) Go to Settings>>Permalinks and resave the settings
5) Clear all types of caches.

Please visit WooCommerce>>WooCommerce Multilingual>>Status tab and check you have any configuration warnings

Please note, I have opened a new ticket for the WPML Registration issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. Also, it will help other users with similar problems find solutions when searching the forum. I will get back to you soon on the latest ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

September 15, 2020 at 9:07 pm #7021401

georgeP-29

Hi Bigul

At woocommerce multilingual i am getting an error: You haven't added any secondary currencies.

I did all the steps still the same. I am testing to different browsers as a guest or incognito and i have the same problem everywhere.

hidden link

The problem happens usually after added 3-4 products and some times after 6.

Please check the video i am adding a product and is deleting the previous.

September 16, 2020 at 10:25 am #7025915

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

September 18, 2020 at 12:46 pm #7045765

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and for sharing the login information. But I am unable to access the site Dashboard and only can access the My Account section of the site. Most probably because of the user permissions. Please check.

--
Thanks!

Bigul

September 18, 2020 at 12:51 pm #7045865

georgeP-29

Please check again, i forgot to give you admin permissions.

September 18, 2020 at 1:46 pm #7046307

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can access the site backend now and the settings look okay. Please tries the following steps after a full site backup and check is there any difference in the result.

1) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

2) Clear all types of caches
3) Go to WooCommerce>>WooCommerce Multilingual>>Categories tab
4) Click on *Synchronize Product categories assignment in content* button on the bottom of the screen and wait until the process complete
5) Go to WooCommece>>Status>>Tools and clear the transients, caches, and sessions
6) Then clear all types of caches

--
Thanks!

Bigul

September 18, 2020 at 2:35 pm #7046851

georgeP-29

Is still the same problem nothing changed.

September 18, 2020 at 6:40 pm #7048329

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. So please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server. It will also help us to troubleshoot the issue without affecting your live site.

--
Thanks!

Bigul

September 19, 2020 at 12:22 am #7048989

georgeP-29

Ok i have install duplicator

September 19, 2020 at 6:10 pm #7051489

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a copy of the site, will debug it further and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 21, 2020 at 9:13 pm #7063089

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The issue is existing on my local copy after the initial troubleshooting steps. Therefore I am consulting about this with our second-tier team for an expert opinion. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

September 23, 2020 at 7:04 pm #7083511

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I have escalated the ticket to our second-tier team for further debugging. Because the error still exists after the primary debugging procedures. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul