This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Andreas W. 8 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
January 28, 2019 at 1:14 pm #3135597

Павло Сидорук

I want to approve the comment. I see that there are lunches, but they are not reflected. If you turn off WPML Multilingual CMS then everything is ok

January 28, 2019 at 2:08 pm #3135932

Павло Сидорук

Tried to disable all plugins. Comments are displayed when I turn off WPML Multilingual CMS

January 28, 2019 at 3:52 pm #3136402

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Could you please got to Comments and then select "All languages" to be displayed in the admin toolbar (top).

Please let me know if this solved the issue.

Further, could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 768M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Kind regards
Andreas

January 28, 2019 at 4:42 pm #3136672

Павло Сидорук

We have completed your recommendations. Nothing changed

January 28, 2019 at 11:35 pm #3137651

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

January 29, 2019 at 10:42 pm #3141792

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I can see by connecting to your site that you do have currently pending comments that are not showing up. Usually, such issue might be solved by changing the admin bar language setting to "All languages" but sadly it does not solve the issue in your case.

You are using a cache plugin. Could you please clear the cache and see of the issue persists? Further, I would like to recommend you a list of top compatible plugins that have been tested by our compatibility team.

https://wpml.org/faq/list-of-top-compatibility-recommendations/

At last if your issue still was not solved please make a complete backup of your site and database. Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information

Please let me know if this solved the issue.

Kind regards
Andreas

January 30, 2019 at 8:29 am #3142617

Павло Сидорук

Hi,
Executed your recommendations, but nothing has changed and I do not see any comments

January 30, 2019 at 3:25 pm #3144716

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

Could you please temporarily disable any additional plugin to see if the issue persists with only WPML and its add-ons active? Further, if the comments work as expected using only WPML could you please reactive each plugin one by one to see which of these plugins is causing the issue?

In case the issue remains uncahnged using only WPML please make sure to change your theme for a moment to a default theme like TwentySeventeen. If the issue disappeaars we will be able to determine that it is the current theme that is causing the issue.

Once we can clarify which plugin or theme is causing the issue we will be able to investigate further on fixing the problem.

In case you are not able to troubleshoot the live site please write me a short message and I will try to obtain a copy from your site using the Duplicator plugin to troubleshoot the issue on a local environment.

Kind regards
Andreas

January 30, 2019 at 3:32 pm #3144788

Павло Сидорук

Hi! I am not in a position to solve the problem, I ask to duplicate and locate the problem locally. Thank you

January 30, 2019 at 7:25 pm #3145461

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Sadly creating a Duplicator package was not successful due to server restrictions of your hosting provider.

You have just received a private message with instructions for migrating your site to our test server.

Please send me a short notification once the migration process is completed.

Kind regards
Andreas

January 30, 2019 at 10:23 pm #3145764

Павло Сидорук

Hi,
Migration completed successfully

January 31, 2019 at 8:35 pm #3149664

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for migrating your site.

After debugging the issue it is clear that we are handling here with an incompatibility issue between the Energico Theme and WPML.

The comments are available once the theme was changed or WPML was disabled once the theme was active.

To reproduce the issue I would kindly like to ask you to install the theme on the following test site.

One Click Login: hidden link

After being able to recreate the issue I will be able to escalate to issue to our compatibility team for further investigation.

Please write me a short notification once the theme has been installed on the test site.

Kind regards
Andreas

February 1, 2019 at 7:56 am #3150623

Павло Сидорук

Hi,
Energico Theme uploaded to the site

February 1, 2019 at 8:25 pm #3153169

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for your patience while I was recreating the issue on a fresh installation.

In fact recreating translations with WPML and the Energico did work as expected. Any comments were available.

While revising your site whihc was migrated to our test server we discovered that inside the funtions.php file shows a custom code edit that when commented out solved the issue.

Here is the code which affected the comments:

remove_filter( 'comments_clauses', array( $sitepress, 'comments_clauses' ), 10, 2 );
add_action('pre_get_comments', function($c){
    $id = [];
    $languages = apply_filters('wpml_active_languages', '');
    if( 1 < count($languages) ){
        foreach( $languages as $l ){
            $id[] = apply_filters( 'wpml_object_id', $c->query_vars['post_id'], 'page', FALSE, $l['code']);
        }
    }

    $c->query_vars['post_id'] = '';
    $c->query_vars['post__in'] = $id;
    return $c;
});

Please take note that our support policy does not cover any custom code solutions.
https://wpml.org/purchase/support-policy/

In this case I will need to refer you to one of our contractors.
https://wpml.org/contractors/

Kind regards
Andreas