Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Farhad 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
September 17, 2020 at 2:02 pm #7037503

Farhad

I am trying to: Translate the hebrew version to english

Link to a page where the issue can be seen: hidden link

I expected to see: Correct styles

Instead, I got: Styles in Elementor wordking great, but not working in the website

Please see the video bellow:
hidden link

Thanks

September 18, 2020 at 8:46 pm #7048681

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

This may be happening because of the older versions of the plugins or conflict with the child theme. So please try the following steps after a full site backup and check is there any difference in the result.

1) Upgrade to the latest version of Elementor - https://wordpress.org/plugins/elementor/#developers
2) Upgrade to the latest version of Elementor Pro - hidden link
3) Visit WPML>>Languages>>Language URL format
4) Choose *Different languages in directories* option and save the changes
5) Visit Settings>>Permalinks, resave the settings
6) Clear all types of caches

If the issue exists, please switch for a moment to the Houzez parent theme and check the problem remains or not. I hope you are using the latest version of Houzez theme - hidden link

--
Thanks!

Bigul

September 21, 2020 at 6:59 am #7056103

Farhad

Hi
I did everything, but the problem is still exists.
The elements in elementor looks great in dashboard, but in the website there don't have their classes.
Now I see this message "strict MIME checking is enabled"
Attached screen

Thanks

September 21, 2020 at 3:05 pm #7061291

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

September 22, 2020 at 3:33 pm #7071445

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am consulting with our team about this issue for an expert opinion now. We will get back to you as soon as possible.

In case of further debugging, please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 22, 2020 at 3:34 pm #7071449

Farhad

Hi
Sure..

Thanks!

September 23, 2020 at 11:53 am #7079483

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. It looks like this issue is happening because of the Elementor CSS settings. Because the page is created using the Elementor builder and it's not a translation made by WPML Editor, so Elementor has all the control over the elements on the page. We can see some related issues in the Elemetor forum. Refer to the following documentation links and the attached image for more details.

https://wordpress.org/support/topic/stylesheets-not-loading-mime-type-error/

hidden link

Therefore it will be great if you can consult about this with the Elementor support team. Please check and let me know your feedback.

--
Thanks!

Bigul

September 23, 2020 at 1:54 pm #7081121

Farhad

My issue is resolved now. Thank you!