Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: The calendar of'The Events Calendar' by 'Modern Tribe, Inc. is not changing the language (days and months names) when changing the language with the Language Switcher. Solution: 'The Events Calendar' is not officially compatible with WPML. Nevertheless, unchecking the 'Enable the Month View Cache' option in the plugins settings Events -> Settings -> Display (tab) solved this problem.

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.11 hours from now. Thank you for your understanding.

This topic contains 10 replies, has 3 voices.

Last updated by Itamar 2 years, 3 months ago.

Assigned support staff: Itamar.

Author Posts
July 10, 2017 at 1:41 pm #1315818

georgeA-5

Hello,
I am having a problem with the change of language on the events calendar plug in.

From what I came up to after searching, the problem had been mentioned by other users too.. When switching months at a calendar, the languages are getting mixed up.

Is there any solution for this issue?

Thanks

July 10, 2017 at 4:58 pm #1316034

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello.

Thank you for contacting the WPML support forum.

Are you referring to 'The Events Calendar' by 'Modern Tribe, Inc.'?
If so then it might be a compatibility issue as it is not in our compatibility list here.
https://wpml.org/documentation/plugins-compatibility/
You write: ".. When switching months at a calendar, the languages are getting mixed up."
Could you elaborate on this issue, please?
What exactly is getting mixed up?
Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.
Can you also share a link with me to where you so this problem mentioned by other users?

Thanks,
Itamar.

July 11, 2017 at 7:47 am #1316404

georgeA-5

Hi Itamar,
Thanks for your answer.

Yes, that is the plugin I am talking about.

This is another question I found in the forum
https://wpml.org/forums/topic/the-events-calendar-cambia-i-noni-di-mesi-e-giorni-alla-lingua-default-del-sito/

To be more specific about the issue I was talking about, even if I am on the english page I see the calendar in Greek (image en1) and when I click the previous or next month buttons at the bottom, it redirects to the greek page of calendar. (image en2)

en2.PNG
en1.PNG
July 11, 2017 at 7:04 pm #1317170

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

When I'm checking your site now I can see that in the first time that I visit the seminars' page the calendar shows fine; it is in English.
Please see attached screenshot calendar-in-english.jpg
The problem starts when paginating to the other months.
I think that we are looking here at an ajax problem.
Please try the following.
1. Go to WPML -> Languages.
2. Scroll down to the 'Language filtering for AJAX operations.'
3. Check the checkbox 'Store a language cookie to support language filtering for AJAX' and save.
Please see attached screenshot store-ajax-cookies.jpg
4. Go to the front-end and check if it is working correctly now.

Thanks,
Itamar.

calendar-in-english.jpg
store-ajax-cookies.jpg
July 12, 2017 at 3:03 pm #1317940

georgeA-5

Hi!

The steps you suggested, fixed the issue with the pagination of the months.

But the problem is now that when I am in the calendar page and I hit the other language button on the top right corner (for example, when I am at the greek calendar and I click the EN button), the language of the calendar is not changing.
When I hit the next/previous month at the bottom of the calendar, it then changes to the correct language.

July 12, 2017 at 6:32 pm #1318169

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

I've installed this plugin on my local server and tested the issue.
From this testings, I've discovered that there is another issue with this plugin and the Language Switcher.
This issue is described in this forum ticket.
https://wpml.org/forums/topic/ruta-del-language-switcher-no-ok-con-el-plugin-the-events-managers/
In any case, I do not see that the above problem is happening with your site, but I could not replicate your issue on my local site.
In the plugins settings Events -> Settings -> Display (tab) there is an option 'Enable the Month View Cache'.
Please see attached screenshot Enable-the-Month-View-Cache.jpg
Can you, please try to uncheck this checkbox and see if it fixes this problem?

Thanks,
Itamar.

Enable-the-Month-View-Cache.jpg
July 13, 2017 at 8:26 am #1318460

georgeA-5

Hi Itamar.

Yes, this fix seems to have solved the problem.
I will keep testing it the next few days and I'll come back if anything occurs.

Thanks

July 13, 2017 at 9:44 pm #1319227

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

OK, @georgea-5, let's hope for the best 🙂

October 6, 2017 at 2:24 pm #1393759

georgeA-5

Hello,

I am coming back to this problem as it started happening again.
After updating both wpml plugin and "The Events Calendar" plugin, when switching between months the language of the site switches from english to greek and vise versa.

I searched about it a little bit and run into this:
https://wpml.org/documentation/getting-started-guide/language-setup/enabling-language-cookie-to-support-ajax-filtering/
and what is mentioned in the last 2 bullets.

I realized that this happens if I am logged in the site.
If I visit it without logging in, everything looks good.

So the question is if there is anything that we can do to make it work in both circumstances.

Thank you

April 11, 2019 at 4:37 pm #3590705

nickP-2

Hi,

i am facing the same issue here.

i tried the above solution but nothing seemed to work.

Any other suggestions?

Thanks

April 11, 2019 at 8:00 pm #3592517

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This is an old ticket, and things might have changed. Please open a new ticket in our forum and add all the relevant information about the issue that you are having.

Regards,
Itamar.