This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Lauren 2 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
July 21, 2019 at 3:09 pm #4252659

alexanderF-32

I am trying to: Translate my woocommerce products

Link to a page where the issue can be seen: only in admin panel hidden link

I expected to see:

Instead, I got:

July 22, 2019 at 1:52 am #4253083

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

It seems that you have a similar issue with one of our client. Could you please try the solution provided by our supporter and check if also resolves your issue.

https://wpml.org/forums/topic/warning-preg_match-expects-parameter-2-to-be-string-message-issue/#post-2664267

Please let me know how it goes.

Kind regards,
Dennis

July 22, 2019 at 4:24 pm #4259873

alexanderF-32

"Thank you. On the WPML > Settings > Custom Fields Translation > Show system fields, I set the "_file_paths" field to "Copy". I'll attach an image for you to see.

Then I updated the post in Spanish and clicked on the "Update" button. After following these steps, the warning message is no longer displayed.

Please, could you test if your site is working properly?

Thank you."
Im trying. but I can't search this "_file_paths" in my "Custom Fields Translation"

July 23, 2019 at 3:19 am #4262507

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Have you tried clicking the 'Show system fields' link just below the 'Custom Fields Translation' section of WPML > Settings?

If you can't still find it, I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

July 25, 2019 at 9:12 am #4281201

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us the access information.

To further debug the issue, I have created a duplicator package. I will download a copy and try deploy it on my local machine. Then I will continue debugging your site locally so as not to affect your site and will give you feedback when I got some results.

Kind regards,
Dennis

July 26, 2019 at 4:42 am #4287329

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

On my local test environment the issue does not seem to happen when creating a new product. Is it also the case at your end? It could be that the existing products has something that triggers the warning error. It could also be that product data for existing products is corrupted. If that's the case, a workaround would be re-creating the products. Could you please try to re-create one product and check if the issue still occurs?

Please let me know how it goes.

Kind regards,
Dennis

July 26, 2019 at 4:40 pm #4291071

alexanderF-32

Hi Dennis.
I m try add new varitable products and I have error...
"Warning: preg_match() expects parameter 2 to be string, array given in /data03/virt75594/domeenid/www.****.ee/htdocs/wp-content/plugins/wpml-translation-management/classes/menu/translation-editor/class-wpml-translation-editor-ui.php on line 172"
hidden link

I have one more question about Custom Product Tabs (by YIKES, Inc.). I need create new support ticket?

July 31, 2019 at 3:53 pm #4316257

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, my apologies for the late reply. Dennis is off, so I will be handling this ticket from now on. I hope that is okay.

As for the error you are seeing, let's try this. Please be sure to make a full backup of your site and database.

Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

After these steps, do you still see the error? In regards to the custom tabs issue, please open a separate ticket for this issue specifically. Thanks!

August 1, 2019 at 5:20 pm #4324495

alexanderF-32

Hi,Lauren
I did everything what you said. I still look erros 🙁

Warning: preg_match() expects parameter 2 to be string, array given in /data03/virt75594/domeenid/www.%%%%%.ee/htdocs/wp-content/plugins/wpml-translation-management/classes/menu/translation-editor/class-wpml-translation-editor-ui.php on line 172

August 2, 2019 at 8:04 pm #4332445

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me. I used the Duplicator snapshot to set up a copy of your site locally, but I am not able to reproduce the error locally. I did not make any changes, just tried opening the translation for the product you shared in the screenshot. I could not get the error to appear. Since the only difference between your site and my test site is the hosting environment, could you please check with your hosting provider and ask them to check the server logs for anything that could point us in the right direction?

Lastly, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WooCOmmerce and WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, do you still see the error?

The topic ‘[Closed] Problem with "expects parameter 2 "’ is closed to new replies.