This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 1 month ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 6, 2018 at 11:01 am #2615550

maratC

Greetings!


I have another issue with WPML plugin.

hidden link

There is a problem with Features translation on every single property page. As a matter of fact, I have translated them all in every language I need. But for some reason, an only in this part of property page, it is not translated. So that in every language there is only french text. How can I fix that?

Regards,
Marat

August 6, 2018 at 7:01 pm #2617146

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I'm sorry but I can't see the issue you are referring to. Could you attach some screenshots in your next message and highlight the features that doesn't show translated?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

August 14, 2018 at 9:17 am #2642804

maratC

Greetings!

Sorry for not replying before... I am dealing with several issues at the same time....
Look, if you will click on any object for example this one
hidden link
ans scroll down, you will see there is a features box...
So in every language it displays only french language text in this box.

August 14, 2018 at 5:55 pm #2644207

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case you should be able to translate this custom fields by going to WPML -> Settings -> Custom Fields Translation (you may need to click on 'Show system fields') -> Set the fields to 'Translate' -> Save the changes.

Then translate the posts again.

Could you tell me the result of the steps above?

Best regards,
Carlos

August 20, 2018 at 11:34 am #2659140

maratC

Greetings!

Those fields (all kind of features fields) have been already set to Translate long time ago.
So apparently this solution doesn't help. If you want, I can give my access details, so that you could have a look inside the admin panel of my WP site.

Regards,
Marat

August 20, 2018 at 5:39 pm #2660436

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marat,
Thank you very much for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Best regards,
Carlos

August 22, 2018 at 5:42 pm #2667600

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marat,
Thank you very much for the informatino provided.

However I will need access to the backend of the site (wp-admin). I have your next answer private again so you can provide the necessary credentials.

Looking forward to your answer.
Best regards,
Carlos

August 22, 2018 at 7:15 pm #2667871

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marat,

I would like to ask you to follow this steps:
- Go to Properties -> Features -> Translate all untranslated features to all languages.
- Go to Properties -> Translate the properties to all languages.
- Go to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button.
- Flush all cache memory that might exists.

Could you tell me if the issue persists after the steps above?

Best regards,
Carlos

August 23, 2018 at 7:50 am #2668983

maratC

Greetings!

So I have tried to translate a property, not all of them, cause there are more than 6000... Apparently, the problem lies there. Only translated properties will have these features translated.
Now, I have a few questions...
1. Is there a way to pur the features text in Strings list, so that they could be translated as strings?
2. Will the translation of all properties cause their duplication? I mean, in terms of disc space, will cause a drastic effect?
3. Is there a way to translate all the properties in bulk?

Regards,
Marat

August 23, 2018 at 3:50 pm #2670802

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Marat,

1.- No, taxonomies have their own section to be translated. In this link you will find more information about taxonomy translation: https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

2.- No, the taxonomies will only be translated once and the referenced by all the posts. That's why, when you are translating a post with the Translation Editor there is a warning message in the taxonomy section.

3.- It is possible to 'copy' the taxonomy terms to all languages but not translated them in bulk.

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos