This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Itamar 4 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
May 28, 2019 at 1:04 pm

sabikC

I am trying to: translate all the web site, is ready but home redirection language is not working fine.

Link to a page where the issue can be seen: Home page Spanish flag redirect to domain with "hidden link" (BAD URL), this problem is only in home page.

I expected to see: hidden link

Instead, I got: hidden link

Please Help

May 28, 2019 at 5:35 pm #3909097

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see this problem on your site. It is happening when the Language Switcher is being used. But when going directly to maquindus.com/?lang=es it works. Please correct the following and see if it helps to solve the issue.

1. Update WordPress to its latest version (you are using an old version at the moment).

2. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

3. Try the troubleshooting section.
3a. Take a backup of the DB of your site.
3b. Go to WPML -> Support -> Troubleshooting (link)
3c. Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Fix element_type collation'
- 'Set language information'
- 'Assign translation status to duplicated content'
- 'Fix post type assignment for translations'

*** Please make a backup of your database before using this.***

Could you please perform those procedures and see if they help?

Thanks,
Itamar.

May 28, 2019 at 7:13 pm #3909673

sabikC

HI, i do all the actions and the problem persists ..
As they realized, the problem is the Language Selector ... and only on the homepage ..

In the internal pages works well ..

There is no additional CSS, no plugins etc. I have several WPML installations on this server and there are no problems because they work well.

Please, I need support. The theme used is Divi by Elegant Themes.

Thank you.

-

Hola realice todas las acciones y el problema persiste..
Como se dieron cuenta el problema es el Selector de Idiomas.. y solo en la pagina de inicio..

En las paginas internas funciona bien..

No hay CSS Adicional, ni plugins etc.. Tengo varias instalaciones de WPML en este servidor y no hay problemas por que funcionan bien.

Por favor necesito soporte. El tema utilizado es de Divi de Elegant Themes.

Gracias.

May 28, 2019 at 7:25 pm #3909727

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

Please now try this.
I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentynineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

May 28, 2019 at 7:52 pm #3909901

sabikC

Hello, the problem persists. I will attach screenshot ..

No plugins installed. Only WPML.

I have several wordpress with WPML on this server.

I need help with the redirection ----- MY DOMAIN.com ____ /? Lang = es --- THAT ONLY APPEARS ON THE HOME PAGE in the WPML language selector (that's why I ask for your help)

I spent days looking for the solution with all kinds of support (hosting, the theme, etc ...)

I need 5 minutes of your time to review my site.

Thank you.

-

Hola el problema persiste. Voy a adjuntar screenshot..

No hay plugins instalados. Solo WPML.

Tengo varios wordpress con WPML en este servidor.

Necesito ayuda con la redirección ----- MY DOMAIN.com____/?lang=es --- QUE SOLO APARECE EN EL HOME PAGE en el selector de idioma de WPML (por eso les pido ayuda)

He pasado dias buscando la solución con todo tipo de soporte (hosting, el tema etc..)

Necesito 5 minutos de su tiempo para revisar mi sitio.

Gracias.

May 28, 2019 at 7:59 pm #3909935
sabikC

Another problem .. I wanted to use the option of different directories, as I always do and not Language name added as a parameter (hidden link - Spanish). I'm using it because
and it was not possible and it shows this message. "It looks like languages per directories will not function."
All the suggestions that are listed were made and this error continues to appear.

New threads created by Itamar and linked to this one are listed below:

https://wpml.org/forums/topic/split-languages-in-directories-are-not-working-on-homepage/

May 29, 2019 at 9:19 pm #3918707

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

After the chat that you have just had with Lauren, my colleague the next step that we would like to try is to see if this continues on another server. Therefore I've created a test server where you can migrate your site. The process is quite easy. Please see all the details in the next private reply.

Thanks,
Itamar.

May 29, 2019 at 9:21 pm

The topic ‘[Closed] Problem with Home Page redirection ____/?lang=es’ is closed to new replies.