This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by sarah.n 6 years, 7 months ago.

Assigned support staff: sarah.n.

Author Posts
March 20, 2013 at 9:26 am #113344

OlivierL

Hello there,

I'm trying to create a translation of my Homepage (Home) which is a custom page I created in Alterna template (static homepage). But as you can see in that video, something weird happens :hidden link -
When I click on the "+" sign in the Pages overview under german flag to get the Home page in german, I get a new page which says on the top right - language : german, translation of : Home - but once I've published the page, it doesn't appear as a translation of "Home" english page and this option doesn't appear in the drop down under "translation of :"

Thanks by advance for helping me solve this,
Olivier

March 20, 2013 at 10:36 am #113374

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Olivier,

Thank you for the video 🙂

Can you please confirm that you are using the latest versions of WPML and its active add-ons (if using any)?

You can check the latest released versions under "My Account -> Downloads" on this site.

If you need to update, instructions to update can be found here: http://wpml.org/faq/install-wpml/#2 Only backup your database first before you proceed! You can use a plugin for this if you like such as: http://wordpress.org/extend/plugins/wp-db-backup/

March 20, 2013 at 12:17 pm #113425

OlivierL

Hi, Sarah
I've updated a couple of WPML plug-ins but the issue remains.
My german version of "Home" once published isn't connected to "home" anymore which creates problems when I try to set it up as "static page" in Reading.

How can I solve this? and why is the translation "jumps" like that after publishing?

March 21, 2013 at 7:00 am #113643

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Olivier,

I have just sent you an email requesting some further information that will help me assist you further.

March 21, 2013 at 8:00 am #113658

OlivierL

Hi, sarah

I saw your email, integrated installer plug-in and updated all WPML plug-ins which needed to (only a couple) but still the issue remains and it affects the functioning of the language switcher on the "Home" page because no translation recognized.

I have also another issue (you advice me to add it to this conversation) with the navigation -
it doesn't switch languages. It stays on english version even after I set the language switcher to German and that the page content gets displayed in german 🙁

I have tried to synchronize the menus as well because when I go on a german page, the nav bar remains in english ?? but when I tried in "WP Menus Synch" to select all and apply, I get this error message : hidden link

HELP 🙂

March 21, 2013 at 8:16 am #113670

OlivierL

Hoops sorry just saw your email - I'm backing up the whole website (it's gonna take an hour)
then will be creating the access for you 🙂

March 21, 2013 at 9:29 am #113706

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Olivier,

I received your email, thank you. What I am still missing is temporary wp-admin access. Can you please send me that as well?

Thanks!

March 22, 2013 at 9:23 am #114018

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

I have all the information I need now. Thank you. I am looking into it and I will update you here as soon as I know more.

March 22, 2013 at 10:04 am #114035

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Olivier,

Can you please check now?

I had to clean up the trashed "Home" pages you had in English and German and then I had to delete the wrong record in your icl_translations db table connected to the English "Home" page. There was a record of a German page without an element id (have no idea how that got there)

After this was cleared, I could connect the German "Home" page to the English "Home" page using the "This is a translation of" setting (edit translation screen)

P.S I would also encourage you to update the following plugins:
WPML String Translation to 1.6.1
WPML Media to 1.3
WPML Sticky Links to 1.2.1

March 22, 2013 at 10:13 am #114040

OlivierL

FANTASTIC - Sarah -I have no clue neither how that got there (such a mess created with Elegant Theme drag& drop page builder that I used before to create the website - Deep focus template) . You see i'm not a web designer neither a programmer (any idea where i could find someone for some trouble shooting activities like that one - when not linked to WPML:) ? )

I'm going to update the plug-ins you mentioned right now !

now i just have the latest issue with the Navigation which doesn't switch languages. Any idea how to solve that one ?

March 22, 2013 at 10:54 am #114057

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Oh sorry! I forgot about the menus question. Checking that now.

Regarding:

any idea where i could find someone for some trouble shooting activities like that one – when not linked to WPML:) ?

You could try contacting one of our certified partners: http://wpml.org/documentation/support/wpml-contractors/ if you like.

March 22, 2013 at 11:04 am #114060

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Olivier,

Your menu translations were not connected to the original. I just did that for you and things look OK to me. Can you please confirm this on your end?

March 22, 2013 at 11:50 am #114077

OlivierL

Sarah YOU ROCK !!! 🙂

Thank you so much - it works, all of it.
I can't tell you how much it means to me because I was under lots of pressure from my management to get it going after all the issues we had with Elegant Themes.
I'm gonna be a top advocate for WPML.
Your tech support is the best I have seen in a long time.

Have a wonderful week-end !
Olivier

March 25, 2013 at 6:55 am #114456

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

You are welcome Olivier 🙂