This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

In Woocommerce Table Rate Shipping you can set shipping rule which leads to aborting shopping process. However, with WCML active, this rule was ignored.

Solution:

Update WCML to the version newer than 4.3.6

Relevant Documentation:

https://woocommerce.com/products/table-rate-shipping/

This topic contains 60 replies, has 2 voices.

Last updated by Konrad Karpieszuk 12 months ago.

Assigned support staff: Konrad Karpieszuk.

Author Posts
June 22, 2018 at 12:54 pm #2429484

Angeloca

Hello,
when I update to the last WCML the Table Rate Shipping (offical WooCommerce version) "Break" and "Abort" stop working.

They work again after I roll back.

I'd like the ticket to be assigned to Konrad Karpieszuk as he mentioned here https://wpml.org/plugin/woocommerce-table-rate-shipping/#comment-1767860

June 25, 2018 at 7:45 am #2431821

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

Hello, Konrad here

Could I get access to your site's wp-admin? I marked your next reply as private

June 25, 2018 at 9:49 am #2432192

Angeloca

Hi Konrad,
thank you for your answer.

We have currently updated it only in our staging enviroment.

I can give you access to it, but you need to configure openVPN (with a config file that I will send you), in order to reach it.

is that ok?

June 25, 2018 at 9:53 am #2432195

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

OK, so another approach: could you give me detailed steps how did you created your table rate shipping configuration? The best would be with screenshots.

and the steps you take to replicate the issue in the front end.

June 25, 2018 at 10:04 am #2432238

Angeloca

Hi Konrad, sure!

I have a shipping zone for Italy, with two methods: UPS Regular, and UPS Quick Delivery.

When some products (with specific shipping classes) are in the baskets I don't want to offer UPS Regular as a shipment option.

In the screenshot attached you find how it's configured the UPS Regular method. Now it's working, after the WCML update, it doesn't anymore :-/

Let me know if it's enough, thank you 🙂
Best

June 25, 2018 at 11:00 am #2432340

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

did you translate shipping classes and/or content of table rate?

does the issue appear in both languages or only on the secondary?

June 30, 2018 at 11:32 am #2447899

Angeloca

Hi Konrad,
We have translated shipping classes, but did not translate content of the table rate (such as names or labels).

The problem presents itself on the primary language, I will check if it happens also on the secondary one...

July 2, 2018 at 10:43 am #2453156

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

ok, I cant replicate it on clean installation. Maybe because I am missing some step or you have some other part conflicting.

Please:
- disable all other plugins. Leave only WPML related, WC and Table Rate. Disable also other woocommerce extensuins and see if it still occur. Please test on standard wp theme (twenty...)
- if this still occur, please zip your site with database dump and share with me for example with wetransfer.com I am marking your next reply as private, in site address please provide url to wetransfer.com download page

July 12, 2018 at 10:35 am #2489276

Angeloca

Hi Konrad,
Thank you for your reply.

Today I'll try to disable everything and I'll try it also on my local setup.

If it doesn't work, I'll send you the db export

July 12, 2018 at 11:01 am #2489339

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

OK, I will be waiting for the result 🙂

July 12, 2018 at 12:25 pm #2489567

Angeloca

Hi Conrad,
I've tried on a clean install with just WC, WCML and Table Rate, and I can reproduce the issue.

Can you please activate the private answer so I can send you the DB export.

July 12, 2018 at 12:37 pm #2489580

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

I am activating. The best will be if you sent a whole site, not only db.

July 12, 2018 at 12:47 pm #2489607

Angeloca

I forgot the screenshot (you'll find it already configured from the DB, but maybe it helps).

July 13, 2018 at 8:46 am #2491805

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

ok, I confirm this issue.

I emailed Erica (the author of this extension) to ask for advices. We will handle it together with her.

When this is resolved, I will update this ticket.

July 13, 2018 at 9:46 am #2491909

Angeloca

Hi Konrad, thank you

if Erica or you come up with an hotfix could you post it here?
Thanks 🙂

Best