This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The footer menu and page content is missing the translation in the secondary language.

Solution: The footer was not showing because the navigation menu had been set to Italian only in Appearance -> Widgets. I set it to all languages and now it shows in English.

As for the content on the Video Production page, the content on the English page has not been translated.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by giuseppeP-25 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 4, 2018 at 3:13 pm

giuseppeP-25

Hello,
I have a problem with the menu I am putting in the widget (footer).
If I set the menu in Italian, then I see it, but when I go to the English version and I set the footer menu in English, everything disappears.

Can you please check and let me know?
Thank you

October 4, 2018 at 3:52 pm #2788083

giuseppeP-25

Hello,
I realized that I have another problem with the main menu as well!
If I switch from Italian to English, altought the URL is the one of the english website what I see is the page in Italian .... See screenshot!
This happened after the main menu syncronization.
Please let me know!

October 5, 2018 at 9:18 pm #2791708

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

The footer was not showing because the navigation menu had been set to Italian only in Appearance -> Widgets. I set it to all languages and now it shows in English.

As for the content on the Video Production page, the content on the English page has not been translated. Please see my attached screenshot. Once you translate the content, you should be able to see the content in English. Let me know if not.

Please let me know if you need any further assistance and I will be happy to help.

October 6, 2018 at 10:42 am #2792737

giuseppeP-25

Hello Lauren,
I think there are some bugs or incompatibility with the theme because of course, I did have the all the pages translated but for some reasons now the translation is no more there and I have some pages in Italian ....

Regarding the widgets, again, something is not working in the right way. For English, I set the appearance for English language only, but the system doesn't keep that information.
So if I understand correctly, I have to set all languages when I am in the Italian section. Am I right?

I have another small issue in the language menu switcher. As you can see in the attached screenshot the dropdown menu has a too large background. Is there a way to reduce it?

Thank you
Have a nice day!

GP

October 8, 2018 at 1:49 pm #2796284

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

For the widgets, you can either use "All Langauges" or you can create a widget for each language. You just need to be sure to save your changes after you set the language.

If you switch to a default theme, are you able to save your translated content? Also, I saw your screenshot but I am not able to see the English drop down on your live site. You will likely need to add some CSS to your theme in order to change the width of the drop down.

Please let me know if you need any further assistance and I will be happy to help.

October 8, 2018 at 1:56 pm #2796297

giuseppeP-25

Hello,
thank you.

If you use the admin login details I sent you, you should see the English dropdown flag.
Please let me know if you can help with the additional CSS code.
Thank you

October 8, 2018 at 3:02 pm #2796527

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

That background is coming from your theme's menu drop down. In the CSS you have this:

.drop_down .second .inner ul li {
    width: 250px;
}

You can change that width, however, that will change the width for all of the drop down items. Additionally, you can always create a language switcher and place it somewhere other than the main menu. Here is some documentation regarding custom language switchers: https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

October 8, 2018 at 3:13 pm #2796592

giuseppeP-25

Ok, thank you, but is there a way to add additional CSS code for WPML language switcher only?
In the past you sent me something similar...
.wpml-ls-item .sub-nav {
min-width: auto;
padding: 7px 0 0 0;
margin: 0;

but it's not working here.

Thank you
}

October 8, 2018 at 4:03 pm #2796841

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I found the solution previously provided by Yuri. I added the following CSS to WPML -> Languages -> Custom CSS

li .wpml-ls-item {
    width: 60px !important;
}
 
.wpml-ls-item > ul.sub-menu.clearfix {
    width: 60px !important;
}

Please let me know if you need any further assistance and I will be happy to help.

October 8, 2018 at 4:07 pm #2796848

giuseppeP-25

Thank you for support. The only problem is that I have to translate again the pages that disappeared ... and I hope that this will not happen again...
Thanks