This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Yvette 11 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
October 25, 2018 at 8:21 am #2848947

paulL-31

Hi,

I'm doing the translation of the website under hidden link - after I'm pressing the "polish" button, the menu gets crazy. Please see attached screenshot as a reference.

TOP image original - English
BOTTOM image broken menu - polish.

We are using BeTheme.

Thanks for your help in advance,
Regards,
Adrian

October 25, 2018 at 12:38 pm #2849753

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Before I start to troubleshoot this - could you please increase the amount of PHP memory allocated to your WordPress as required for normal functioning of the plugin.

This means adding this line to your wp-config.php file

define( 'WP_MEMORY_LIMIT', '256M' ); 

Then,
- please go to WPML -> Support -> Troubleshooting > Clean up
- select the option to "Clear the cache in WPML"

Then write back with access to your site (wp-admin) if the problem is still present. I am enabling the private area for username/password of a temp user with admin priveleges.

Thanks

October 25, 2018 at 12:55 pm #2849859

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Please re-check the credentials. When I cut&paste them into the logon screen, the system will not accept them.

October 25, 2018 at 1:00 pm #2849862

paulL-31

Please try now.

October 25, 2018 at 1:34 pm #2849953

paulL-31

The details are working for you now?

October 25, 2018 at 5:06 pm #2850565

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes they are - thank you

October 25, 2018 at 5:20 pm #2850593

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

The reason for the disconfigured menu in other languages is due to the custom CSS that you have included which is only targeting the "en" language.

To fix this I replaced your CSS from this:

li#menu-item-wpml-ls-7-en {
    left: 200px !important;
}

to this

.wpml-ls-current-language {
    left: 200px !important;
}

and it seems to now resolve your styling issue.

October 26, 2018 at 5:38 am #2851995

paulL-31

My issue is resolved now. Thank you!

October 26, 2018 at 6:02 am #2852006
paulL-31

Hi,

I cannot find the way, how to make a background of the wpml button blue on mobile only, is always changing on the desktop and mobile and also I wish align it to center and make next to it "+" symbol. Is the thing you can help me out as well?

Thank you. 🙂

New threads created by Yvette and linked to this one are listed below:

https://wpml.org/forums/topic/split-css-questions-on-wpml-button/

October 26, 2018 at 6:59 am #2852080

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I can take a look but as it is not related to the original issue, I have split it into a new forum thread. We can close this ticket definitively now.