This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.11 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by Radu 1 month, 4 weeks ago.

Assigned support staff: Radu.

Author Posts
August 9, 2019 at 7:26 am #4368219

francesco-lucianoS

I am trying to: translate a page into English

Link to a page where the issue can be seen: hidden link

I expected to see: the possibility of viewing the translation in English by clicking on the flag

Instead, I got: I don't see the English flag and the translated page

August 9, 2019 at 10:49 am #4369565

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Francesco,

Thank you for reaching out the WPML support!

Can you make sure that the progress of the translation is at 100%, please? This is the most common issue when the translation is not showing. If this is already done, please give me access to the dashboard area of the website so I can have a quick look at this.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

August 13, 2019 at 10:37 am #4387091

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Francesco,

I checked all the settings from the WPML plugin but I still don't understand why is this happening when trying to access the translation of the homepage.

Can you try to deactivate all the plugins not related to WPML, activate a default theme (like Twenty Nineteen), and tell me if you still have this issue, please? I just want to make sure that none of them are causing this issue (due to some compatibility issue, for example). Please let me know how this goes.

Thanks,
Radu

August 19, 2019 at 12:23 pm #4415877

francesco-lucianoS

It's a site in production so I wouldn't want to do these operations. I try to create a copy and do what you told me. So at present you too can't understand the reason for the problem, the plugin is correctly configured.

August 21, 2019 at 11:21 am #4430667

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Francesco,

Can you tell me if you made any other change to the Shopping page, please? I'm asking this because I checked it again now and I can access the English version now. Can you check this page too?

Thanks,
Radu

The topic ‘[Closed] problem with page translation’ is closed to new replies.