We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client is using the "NextMove Lite - Thank You Page for WooCommerce" plugin and whenever WPML is enabled, he is seeing extra meta info (author, date, folder icon) being displayed on the thank you finished-order page.

Solution:

"Changing wp-content/plugins/woo-thank-you-page-nextmove-lite/includes/xlwcty-public.php" - line 115 to:

add_action( 'parse_query', array( $this, 'parse_query_for_thankyou' ), 11 );

(note the '11') solved the issue.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by dimitrisP-6 5 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 10, 2019 at 1:55 pm #3785179

dimitrisP-6

Hello

The problem i' am facing is that when i activate WPML, the woocommerce custom thank you page shows the Author, Date and a folder icon. In the attached image i have highlighted the problem.

The plugin i' am using is the NextMove Lite - Thank You Page for WooCommerce.

I' am using the latest versions for all plugins.

Thank you for your help

May 10, 2019 at 2:39 pm #3785575

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see, the plugin that you are using is not part of our official WPML-compatible plugin repository here: https://wpml.org/documentation/plugins-compatibility/

This means that there might be some compatibility issues between that plugin and WPML if you experience this only when you enable WPML.

Can you please try this:

- set up a clean WordPress environment where you are using just the WPML plugins, WooCommerce + the plugin that you mentioned and a default WordPress theme like Twentysixteen and see if the issue is still happening

I created an environment like that for you already (you can find it here - hidden link - it is a one-click login type of authentification), in case you want to use that.

All I would need from you is to:

- set up WPML + WooCommerce and install + setup the plugin that you use the way you have it set up on your site
- then try to recreate the issue.

Please let me know how that goes.

If the issue is happening on our servers, too, in a clean install form, then I could forward this situation to our Compatibility department.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 10, 2019 at 5:07 pm #3786967

dimitrisP-6

Hello

Sadly the same thing happens.

Waiting for your help.

Thank you

May 12, 2019 at 5:33 pm #3793485

dimitrisP-6

Hello

I need an update.

Thank you

May 13, 2019 at 11:21 am #3797431

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hello and thank you very much for your patience.

Sorry for the late response but that was caused by the fact that I don't usually work on weekends.

Thank you for setting things up on the sandbox and for running the test. I also ran a test on my own and the same thing happens.

I reported this to our Compatibility team and I created an internal ticket where I am currently waiting for feedback from my colleagues.

I will keep you updated as soon as I have more news on this.

Kind regards,
Mihai Apetrei

May 16, 2019 at 5:53 pm #3828581

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I am back with feedback 🙂

Here is what our developers said:

"Changing wp-content/plugins/woo-thank-you-page-nextmove-lite/includes/xlwcty-public.php" - line 115 to:

add_action( 'parse_query', array( $this, 'parse_query_for_thankyou' ), 11 );

(note the '11') seems to solve the issue.

Can you please test that on your side, too, and let me know if it worked?

I will be waiting for your reply.

Thank you.

Kind regards,
Mihai

May 17, 2019 at 6:32 am #3831629

dimitrisP-6

Hello

I had to try a different thank you page plugin because of time pressure to complete the website.

Can you please try this fix on the demo website you provided in order to see if it works and use it in future projects ?

Thank you

May 17, 2019 at 3:10 pm #3835487

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I can confirm that the solution our developers recommended worked on my test in the sandbox I created.

Here is where you can see it at work: hidden link

Just check the page with WPML active and then refresh it after you disabled WPML.

Just a note that this sandbox will be active for 7 days since the last login.

If in 7 days no one logs into the site, the sandbox will not reset the time and is automatically deleted.

Can you also please mark this ticket as resolved?

Just a note that I am not working on the weekends so if you have any more questions regarding this matter and you write me tonight or this weekend, I will be able to answer you at the beginning of next week.

Kind regards,
Mihai

May 20, 2019 at 6:32 am #3843959

dimitrisP-6

My issue is resolved now. Thank you!