This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 2 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 17, 2019 at 8:18 pm #4233333

Arsen

Dear,

The webslte: hidden link
It is about the problem with sitemap.xml.

This is the message we sent to the wordpress theme:

We noticed that we don't have a sitemap for /fr-be, only for the default language.

if we read this post WPML should be compatible with Yoast
https://wpml.org/errata/different-sitemaps-per-language-while-using-wordpress-seo-by-yoast/

But if we go to hidden link
we only find /nl-be/ pages in these sitemaps.

We also found a énd xml sitemap plugin, that could be conflicting?
hidden link

After we got the message from the wordpress theme:

The problem in WPML and Yoast SEO integration. When you will deactivate the WPML function to show the prefix of the main language all will be fine (in this way, the URLs will be hidden link, not hidden link). But if you will activate this WPML function, the problem will come back. Also, we have checked this problem on other websites and the result is the same. As this is WPML problem, I think will be better if you will write to WPML support.

Please find attached file we have received from wordpress theme.

Awaiting for your reply.

Thank you in advance,

July 17, 2019 at 11:08 pm #4233897

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

If you have the function use directory for default language you are adding /nl-be/ in your URL which will bring up only the /nl-be/ sitemap.xml pages or posts

if you change in the URL the /nl-be/ to /en/ then you should be able to see the /en/ ones

according to the documentation if i understand correctly you should have one sitemap for all the languages.

i have updated our developers and will update you soon

July 19, 2019 at 5:11 pm #4247605

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

please try the following :

1. Download and install Yoast SEO Multilingual and activate it on your site.
https://wpml.org/downloads/

2. Go to WPML=>languages->enable “Use directory for default language”

3. verify in the front end that it is working as expected when viewing the sitemap on hidden link

July 25, 2019 at 3:11 pm #4284567

Arsen

Dear,
Thank you for your reply.
We had done as you said. It start working and now it stopped working.
Link: hidden link

We do not know the reason why.

Can you please check?

Thank you in advance.

July 26, 2019 at 7:43 am #4287959

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i have not been able to reproduce this issue on my testing site

hidden link

1. Please verify that yoast is currently updated and activated

2. Is the issue still happening with WPML deactivated ?

if yes i would like to take a closer look if possible

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

The topic ‘[Closed] Problem with sitemap’ is closed to new replies.