This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.12 hours from now. Thank you for your understanding.

This topic contains 29 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 28, 2019 at 3:02 pm

vittorioF

Hi,

I have a problem with the slug translation of a custom post type.

When I create the translation of a page from the main language (Italian) to the secondary language (English), in the editing screen (screenshot) I see the slug of the product not in English, although I have set the translation from the WPML settings.
When I click on the preview it also shows me the page, but the post type slug remains untranslated.

I followed all the indications I found in the forum, but I still have the problem.

August 29, 2019 at 10:00 am #4479655

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I just visited the site and I assume that the "Portfolio" post type is the one you are referring to. In this case you need to follow this steps:
- Go to WPML -> Settings -> Post Types Translation -> Select the "Portfolio" -> Change the slug there.

As an alternative you can:
- Go to WPML -> String Translation -> Search for the slug -> Translate it there.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

August 29, 2019 at 10:06 am #4479787

vittorioF

Hi Carlos!

1) I've already done these operations, in fact if you go to the pages you should see them translated.
Although I still have problems, do you have any idea what the problem might be?
2) Memory limit increased.

August 29, 2019 at 11:38 am #4480563

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

Just to confirm: You desire to show 'prodotto-orphea' in Italian and 'product-orphea' in English, correct?

Regards,
Carlos

August 29, 2019 at 11:42 am #4480575

vittorioF

Yes, in "products-orphea".

August 29, 2019 at 12:40 pm #4480933

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I applied several troubleshooting options but the issue persists. I have created a test site with a fresh new WordPress install and WPML plugins installed and setup too.

I kindly ask you to log in the test site by using this link: hidden link
and install the plugin or theme that creates this custom post type and let me know if the issue persists.

August 29, 2019 at 1:00 pm #4481131

vittorioF

Hi Carlo,

I added the themes.

Thanks so much.

August 29, 2019 at 1:51 pm #4481493

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Could you tell me if the issue persists?

Regards,
Carlos

August 29, 2019 at 2:01 pm #4481585

vittorioF

Hi Carlos,

in sandbox I set the slug post type and it works.
Instead in the site I continue to have the problem.

Thanks so much.

August 29, 2019 at 2:08 pm #4481645

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

It seems we might be facing an interacction issue with a third party functionality. In this case I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

August 29, 2019 at 2:44 pm #4481879

vittorioF

Hi Carlos,

I deactivate all the plugins and I find the plugin that cause the conflict: "wp-category-permalink".
I use this plugin for create a URL that have the category, for example: mysite.com/products/category-product/my-product.

How can I add, with WPML, the main category in the slug?

August 29, 2019 at 7:41 pm #4483319

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I think you can add the main category in the slug in Settings -> Permalinks

Regards,
Carlos

August 30, 2019 at 7:47 am #4485135

vittorioF

Hi Carlos,
in this page i see only the structure for all the permalinks.
If I enter "/%category%/%postname%/" it doesn't work.
The plugin allowed me to add it.
Could you tell me how to add in the name of the category in the slug?

Thank you so much for your support.

August 30, 2019 at 9:00 am #4485455

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Could you explain what do you mean by: "it doesn't work"?
- Does the site throws an error? or the URL structure is not what you expected?

Regards,
Carlos

August 30, 2019 at 10:06 am #4486237

vittorioF

If I set the permalink in this way (screenshot 1).
Then I go in one article of my custom post type but I don't see the category in the slug (screenshot 2).
I need to add the category to the slug, for example: mysite.com/product-category/product-name