Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

When the Vik Rent Car plugin is installed the translated pages have a different layout (width, and page's title).

https://vikwp.com/plugin/vikrentcar

Solution:

1. To stay on the safe side, take a full backup of your site before proceeding.

2. Go to the editing page of the English original page.

3. If the translation needs an update (two arrows circle icon) or not complete (gear icon), then complete the translation.

4. Switch the language at the top admin bar to edit the translation (in the example, the German translation).

5. Once you are on the editing screen of the German page, you will see a warning that says that you are trying to edit using the standard WordPress editor while the page was translated with WPML's Translation Editor.

6. Press the 'Edit anyway' button.

7. On the right sidebar in the 'Language' section, press the 'Translate independently' button.

8. Press the 'Overwrite with ENG content' button and confirm when prompted. The page will refresh, and you will need to press the 'Edit anyway' button again.

9. By using the admin Language Switcher, switch back to edit the English page.

10. Now, translate the page again with WPML's Advanced Translation Editor by pressing the pencil icon in the 'language' section. You will notice that the Translation Editor has all the translations of this page in memory. Complete the translation.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 15 replies, has 3 voices.

Last updated by touloupasS 2 weeks, 5 days ago.

Assigned support staff: Itamar.

Author Posts
April 9, 2021 at 12:13 pm #8501703

touloupasS

Hi,
I am building a site with DIVI and I use WPML. I have 6 different languages. I use Advance Translator Editor in order to give the translation to other users.
All pages layouts are the same, except for Deutsch.
In the attachments you can see the different layout of content. The ENG is the right one.

Can you please tell me how to solve this?
I read the guides but with no success.
Thank you
Stelios

Different Layout Eng.png
Different Layout Deu.png
April 10, 2021 at 1:10 pm #8506837

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

Please provide us your debug information.
You can find them in WPML > Support > debug information (link)
Copy them and paste them into the box I'll enable in the next reply.

April 12, 2021 at 7:46 am #8514015

touloupasS

--removed by support--

April 12, 2021 at 8:36 am #8514859

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

I'm sorry, but I can not read the debug info in the way you shared it with us. I've removed this data from the thread. You can read a detailed explanation about how to share the debug info correctly here.
http://wpml.org/faq/provide-debug-information-faster-support

I assume that you read our guide on how to work with WPML and Divi.

https://wpml.org/documentation/theme-compatibility/divi-builder/

You might have a layout problem with the Deutch translation because the transition workflow was not followed correctly. It usually happens when the translated page had been edited with the Divi or WordPress editor and not with WPML's Translation Editor. Or edited with the Divi or WS editor after it was edited with WPML's Translation Editor. If this is the cause of the issue, you might correct this by making a small change in the original page and pressing the Update button. Then it will trigger an update also for the translations. So you will need to update the translations. If this is indeed the issue, it may solve the layout problem that you are having.

Regards,
Itamar.

April 12, 2021 at 12:04 pm #8516907

touloupasS

Ok, now i saw the box to paste the debug info.
Thank you for the instructions. The problem is that for every page when I hit Update, the Advanced Translation Editor is opened, except for Deutch!!
How can I force the opening of Advanced Translation Editor?
I did as you suggest without success.

Thank you
Stelios

April 13, 2021 at 9:54 am #8523805

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Stelios, and thanks for attaching the debug information.

According to the debug info, it seems that you used the Classic Translation Editor and switched to the Advanced Translation Editor. What had probably happened is that because you translated the German pages with the Classic Translation Editor, you keep getting to edit the German content with this editor. The settings that control which Translation Editor is used are in WPML -> Settings -> How to translate posts and pages. For 'Content that was created with WPML's Classic Translation Editor,' you might see the option 'Use WPML's Classic Translation Editor' selected. There, you can switch to the option 'Switch to using the Advanced Translation Editor (old translations may be unusable)'. But as mentioned, you might lose the old German translations and need to translate the content again. The following link to our documentation explains in detail the Translation Editor options and memory functionality.

https://wpml.org/documentation/translating-your-contents/translation-editor-options/

https://wpml.org/documentation/translating-your-contents/how-wpml-keeps-track-of-your-translations/

Please let me mention again that if the translation layout is correct in all the other languages except in German, then probably the translation workflow for the German pages was not followed correctly. I am talking about the workflow we explain in our Divi guide here.

https://wpml.org/documentation/theme-compatibility/divi-builder/

It might be that the German pages were edited with the Divi editor and not with WPML's Translation Editor. If that happened, then another option that you can try is the following.

1. In Pages -> All Pages, switch to the German language (German link above list, or select the German flag in the top admin bar).

2. Trash all the German pages with the wrong layout. And also, permanently delete them from the trash section.

3. Make sure that all the original English pages are updated and layout-wise look as they should.

4. Go to WPML -> Translation Management -> Translation Dashboard and send those pages to translation again.

5. Translate the German pages and make sure that the translations are 100% complete.

Now the layout should be the same as on the original pages.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Regards,
Itamar.

April 14, 2021 at 7:34 am #8531533

touloupasS

Hi,
after applying your suggestions, the problem is still there.
From the beginning I used the Advanced Translation Editor (ATE).
The problem is in FRA, DEU and ITA. (I am really really sorry for missing this). The ENG, GRE, RUS are ok.

I delete the translation of DEU and then I translate it again. The problem is there.

Another problem is that when I am trying to Translate the Home Page for FRA, I cannot. I click the + button under FR, I translate and click Save. But when I refresh pages, the + Button is there again. This is strange.

I give up.. WPML is a little bit chaotic for me (yet!) .
Should i give you credentials to enter my site?

Thank you!

April 14, 2021 at 7:43 am #8531587

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

What you describe in your last reply might be due to the following explanations. This should be fixed in any case, even if not the cause of this specific problem.

By looking at the debug info you have attached, I can see that your server WP Memory Limit is set to 40M. Our recommendations are to have the following as minimal requirements:

- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.

- MySQL 5.6 and above.

Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/

Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.

Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Regards,
Itamar.

April 14, 2021 at 4:04 pm #8537143

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, and thanks for the access details.

I've checked things on your site.

I was able to redeliver the translation with ATE. But before that, I could see in the CTE that the translation of the content into German is styled in how it shows on the frontend. I'm still not sure why this problem is happening. It looks to me that besides Divi there is another plugin is involved in the styling of the pages. Therefore please continue as follows.

If possible, get your site into a minimum environment. The minimum environment in your case means deactivating all plugins except WPML. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site, you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Regards,
Itamar.

April 15, 2021 at 5:10 pm #8547637

touloupasS

Hi, I found out it is the VikRentCar plugin that is "making the problem". I contacted their support and they reply

"The problem is very strange indeed.
When VikRentCar is enabled the HTML page structure is different. If I check the HTML source code seems that the page takes a different file layout theme, also in the body class you can find the "single single-page" classes that you can not find in the normal layout.
Although, the most strange thing is that VikRentCar is not loaded on that page. None of our code or js is loaded on that page, so it is quite strange this depends on VikRentCar.
Divi or WPML should check the source code page and should give us more technical information about it, otherwise, it is impossible to know where to look, also because our plugin is not loaded at all on that page.
I'm sorry for not giving you a specific answer, but unfortunately, this problem might depend on loads of things. Furthermore, we have a lot of customers that are using Divi or WPML and none of them have ever told us about a similar problem."

Thank you,
Stelios

April 18, 2021 at 10:11 am #8564055

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

We need to replicate this issue on a fresh WordPress installation. Then I'll be able to escalate it to our compatibility team. For this, I created a test website with a clean WordPress install. You can access it through this link:

hidden link

With this link, you'll be directly logged in.

I already installed the Divi theme on this site. And also configured WPML to have English as the default language and French as the second language.

Could you please install the VikRentCar plugin and see if the issue is replicable on a clean WordPress installation?

Please also make sure that you are installing the latest version of the plugin.

When everything is finished, and you can replicate the problem, please let me know.

Thanks,
Itamar.

April 20, 2021 at 7:00 am #8577769

touloupasS

Hi,
I did as you asked, but I cannot replicate the problem. I don't know how to replicate it!

Thank you
Stelios

April 20, 2021 at 7:55 am #8578319

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Stelios, and thanks for trying to replicate the issue on the sandbox site.

We can continue to debug this issue on a copy of your site. For this, I'm creating a temporary server for you to migrate your site. The process is quite easy. Please see all the detailed explanations of what you need to do in the next private reply.

Regards,
Itamar.

April 20, 2021 at 8:49 pm #8585161

touloupasS

Hi,
I migrated the site for further debagging.

Thank you,
Stelios

Automated WordPress Migration by BlogVault - migrate.blogvault.net.png
April 21, 2021 at 11:13 am #8589939

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, and thanks for migrating your site to our server.

I investigated the issue on the copy of your site and found out that, indeed, the problem is happening when the Vikrentcar plugin is active. Luckily I could find a workaround that fixes this issue. If you first duplicate the page with WPML's duplicate feature and then re-translate the page, you get the same layout. I tried it on the '100% Insurance' page, and it works. Please check it here.

English hidden link
German hidden link

Now you can see that the German translation has the same layout (width of the content) as the English original page. And the page's default title, '100% Versicherung' is not showing as it is on the English page.

Here are the steps that you need to follow to implement this workaround.

1. To stay on the safe side, take a full backup of your site before proceeding.

2. Go to the editing page of the English original page.

3. If the translation needs an update (two arrows circle icon) or not complete (gear icon), then complete the translation.

4. Switch the language at the top admin bar to edit the translation (in the example, the German translation).

5. Once you are on the editing screen of the German page, you will see a warning that says that you are trying to edit using the standard WordPress editor while the page was translated with WPML's Translation Editor.

6. Press the 'Edit anyway' button. Please see the attached screenshot edit-anyway.jpg.

7. On the right sidebar in the 'Language' section, press the 'Translate independently' button. Please see the attached screenshot trans-ind.jpg.

8. Press the 'Overwrite with ENG content' button and confirm when prompted. Please see the attached screenshot over-conf.jpg. The page will refresh, and you will need to press the 'Edit anyway' button again.

9. By using the admin Language Switcher, switch back to edit the English page.

10. Now, translate the page again with WPML's Advanced Translation Editor by pressing the pencil icon in the 'language' section. You will notice that the Translation Editor has all the translations of this page in memory. Complete the translation.

Now the translated page would have the same layout, and the original page title will not show.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

I need to mention that the Vik Rent Car plugin (hidden link) is not known to us and is not on the list of our officially compatible plugins here.

https://wpml.org/documentation/plugin/

It would be great if you could contact the authors and urge them to join our Go Global Program. You can find details about it here.
https://wpml.org/documentation/theme-compatibility/go-global-program/
We will be happy to cooperate with the authors in making their plugin officially compatible with WPML.

edit-anyway.jpg
trans-ind.jpg
over-conf.jpg