This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 7 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 20, 2019 at 12:58 pm #3221835

jasonN-10

Hello

We are using Woocommerce Multilingual to manage the woocommerce products. In the store URL We have specified the following as the base urls for Spanish language

Product Base: productos/%product_cat%
Product Category Base: productos

The Product category page works fine, but the single product pages loads up posts(like a blog page). For example:

hidden link
hidden link

Please check and let us know how can we fix it.

Thanks

February 20, 2019 at 9:59 pm #3223945

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed investigation, can you please confirm if you have followed our instructions regarding WooCommerce urls translations from https://wpml.org/documentation/related-projects/woocommerce-multilingual/#urls? Please, let me know if it helps, have a nice day.

February 21, 2019 at 4:06 am #3224809

jasonN-10

Hello

Yea We have followed the instructions mentioned in the above url, and using different slugs accordingly.

Please check

February 21, 2019 at 3:04 pm #3228302

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

February 22, 2019 at 6:22 pm #3233663

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a look in your website and tried to setup different permalinks structure for issue troubleshooting purposes, however, it was not possible since your .htaccess is not writable, please make sure it is has the proper permissions, you can learn more regarding it at: https://codex.wordpress.org/Changing_File_Permissions#.htaccess_permissions or update your FTP details with working crendentials and I can change these permissions for you. Thank you for your collaboration and patience, have a nice day.

March 8, 2019 at 12:18 pm #3292050

jasonN-10

Hello Marcos

Apologies for the delay, .htaccess has 644 as file permission and I am not getting the option to mark this message as private to share SFTP .

Please check

March 8, 2019 at 5:22 pm #3294638

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, provide us with your working FTP details so I can proceed with the issue investigation. The private reply fields are enabled for your next reply so you can send them safely. Please, let me know if you need any additional details. Have a nice day.

March 11, 2019 at 6:11 pm #3315831

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried to connect to your host via FTP using the provided details, unfortunately it is not possible, I always get a timed out message, please, rewiew these details and check if there's any firewall blocking my connection trials.

By the way your .htaccess file doesn't seem to be writable as you can see in the provided screenshot. Thank you for your collaboration, have a nice day.

The topic ‘[Closed] Problem with the Store Urls’ is closed to new replies.