This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 1 month, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
September 2, 2019 at 5:49 pm

David Henry

I am trying to: view pages as normal
Link to a page where the issue can be seen:hidden link
I expected to see: a post
Instead, I got: The page isn’t redirecting properly

Hi Guys,

I've deactivate all plugins except WPML String Translation and the problem is still there. I also did this with the theme TwentyNineteen.

I've also gone through the trouble shooting as described on this post:
https://wpml.org/forums/topic/switching-languages-results-in-redirect-loop-err_too_many_redirects/

The site is very much reliant on WPML but how do I fix this?

David

September 2, 2019 at 7:02 pm
September 2, 2019 at 7:52 pm #4499857

David Henry

My original post said WPML String Translation but it's actually WPML Multilingual CMS that is causing the problem.

September 2, 2019 at 8:56 pm #4499953

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Sadly, the previous provided email address is not valid anymore. Please provide new access details on order to debug the site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 4, 2019 at 2:37 pm
September 4, 2019 at 3:33 pm #4512543

David Henry

Duplicator also installed but not activated

September 5, 2019 at 3:20 am #4515123

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing you to let you know that I took a copy of your site but until now i was not able to point out what is causing the redirect issue.

I will follow up on this issue tomorrow and contact you right after.

I hope for your understanding.

Kind regards
Andreas

September 5, 2019 at 6:01 pm
September 5, 2019 at 6:03 pm #4521351

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just sent you a private message with information to migrate your website to our test server.

This waz our developers will be able to have a more detailed look about the issue, without affecting your website.

Leave me a short notification once the migration is completed.

Kind regards
Andreas

September 6, 2019 at 4:37 pm #4526733

David Henry

It looks like you disabled a lot of plugins etc. which is what we did before we contacted you. I'm not sure why but this looks to have fixed the issue. Let's hope its not temporary.

September 6, 2019 at 5:02 pm #4526863

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello David,

Thank you for the information. I am glad to hear that at the moment the site runs normal.

Sometimes simple de- and reactivating can solve issues, or the issue was related to server cache or a cache plugin.

In case the issue appears again please let me know or in case this ticket will be closed automatically you can contact us by chat or open a new ticket.

Kind regards
Andreas