This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by marcB-27 1 year, 4 months ago.

Assigned support staff: Bigul.

Author Posts
May 8, 2018 at 10:06 am

marcB-27

Hello guys,
Hope you can help.

- I have a post type called 'beaches'.
- This post type uses a custom URL format: beaches/beaches-on-bonaire/ (see screenshot 1)
- When beaches is not translatable the post can be reached on the expected URL.
- When beaches is translatable:
- - All EN posts are giving a 404
- - All NL posts (that i created after setting the post to translatable) are giving a 404
- When i look into translation management > Multilingual Content Setup > Post type translation i see that the EN slug is the standard WP slug (beach) (see screenshot 2).

My guess would be that this last point is directing us to the issue. The strange thing is that i setup other post types without any problem in the same structure.

What is causing this and how to fix it?
Thanks!

May 9, 2018 at 8:28 am #2046772

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps and check you are getting the expected result.

1) Upgrade to WPML 3.9.4
2) Check the issue is existing or not
2) Visit WPML>>Translation Management
3) Choose *Multilingual Content Setup* tab
4) Unselect *Translate custom posts slugs (via WPML String Translation)* option of *Custom posts slug translation options*
5) Check the issue is existing or not

Please check the attached images for more details.

--
Thanks!

Bigul

May 14, 2018 at 9:42 am #2114446

marcB-27

Hi Bigul,
thanks for the reply. Step #1, updating is giving an error. Can you login and try to update. I created a key, you can find it in my sites overview.
Thanks!
Marc

May 14, 2018 at 5:30 pm #2125325

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marc,

It is happening because you have not registered your site with the WPML.org subscription. We have to register the site to get the automatic updates. Please check the attached images and following documentation for more details. Then please try to register the site once again.

https://wpml.org/faq/install-wpml/#register

--
Thanks!

Bigul

May 14, 2018 at 5:45 pm #2125510

marcB-27

Hi Bigul, i know the procedure. It’s the updating that is giving me a bug. Please try it yourself. You can find the key for this site in my account.
Thanks!

May 15, 2018 at 6:19 am #2129147

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marc,

Thank you for the feedback. We will not be able to access your *My Account* section. So please try the following steps and check the issue is existing.

1) Delete the current site key
2) Create a new key for the site
3) Visit Plugin commercial page and click on *Register WPML* button
4) Add the site key
5) Uncheck the *Keep wpml.org up-to-date about which theme and plugins I use* option
6) Then register with the new site key

--
Thanks!

Bigul

May 15, 2018 at 7:09 am #2129737

marcB-27

Hi Bigul,

Updating worked after following your steps. It was indeed point number five (uncheck the keep
wpml.org up to date) that was causing the error..

I followed the steps given in your first reply. Updating WPML is not solving the problem, still i see the wrong slug in the overview with the slug translation (beach instead of beaches/beaches-on-bonaire/ > see screenshot 1). Unchecking 'translate custom post slugs' is giving an unwanted effect since than the posts share the same slug which is bad practice for SEO.

I want to point out that all the rest of the post types are set up in the same way, and are working as expected (see screenshot 1).

What are the next steps in solving this issue?

Marc

May 15, 2018 at 4:16 pm #2144226

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marc,

Thank you for the updates. It requires further debugging. So please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

May 15, 2018 at 4:40 pm #2144821

marcB-27

Yes, please proces. You have the creds and i allready installed duplicator pro.
Thanks!

May 16, 2018 at 5:45 am #2149726

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marc,

Thank you for the permission. I made a duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

May 16, 2018 at 6:36 am #2150102

marcB-27

Thanks Bigul, if you need any additional info or help, let me know.
Marc

May 17, 2018 at 4:17 pm #2179446

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marc,

It looks like the issue is happening because the *URL slug: beach* string is registered as *beach* instead of *beaches/beaches-on-bonaire* in the String Translation. It works on my local copy after the following steps. Please try it after a site backup and let me know your feedback.

1) Visit *Post Types Translation* section of WPML>>Translation Management>>Multilingual Content Setup
2) Disable the *Use different slugs in different languages for Beaches.* for the *Beaches* Post Type
3) Save the changes
4) Visit WPML>>String Translation and delete the *WordPress* - *URL slug: beach* - *beach* string
5) Enable the *Use different slugs in different languages for Beaches.* for the *Beaches* Post Type
6) Save the changes
7) Then translate the newly registered *WordPress* - *URL slug: beach* - *beach* string

Please check the attached images for more details.

--
Thanks!

Bigul

May 23, 2018 at 2:33 pm #2216375

marcB-27

Hi Bigul,
Thanks. That gave me good directions in fixing the issue.
Marc