This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 6 voices.

Last updated by erikaS-2 4 years, 6 months ago.

Assigned support staff: Andrey.

Author Posts
March 11, 2015 at 8:27 am #575352

Amir
Supporter

There is a problem in WPML 3.1.9, causing pages with non-English characters to appear as 404. We can see it on our site too, in pages such as:
http://wpml.org/he/%D7%AA%D7%99%D7%A2%D7%95%D7%93/%D7%94%D7%9C%D7%99%D7%91%D7%94-%D7%95%D7%94%D7%AA%D7%95%D7%A1%D7%A4%D7%99%D7%9D-%D7%A9%D7%9C-wpml/

This is due to over-sanitation of URLs. We are fixing this right now and will have an update in a couple of hours. Sorry for the mess, we're on it.

This update will be as WPML 3.1.9.1.

March 11, 2015 at 10:24 am #575527

ludwigA

Same problem here, after i did the upgrade, none English character url don't open.
This case is urgent, hopefully someone will reply soon.

This update caused many problems, please test your releases before publishing.

March 11, 2015 at 10:27 am #575533

Amir
Supporter

Yes, very urgent. We're on it right now. We know where it's coming from, just working our how to keep the security closure and avoid this over-escaping of URLs. Almost there.

March 11, 2015 at 10:45 am #575562

Amir
Supporter

It's updated now. 3.1.9.1 is ready in our downloads. It will take about 15 minutes for this update to be available in your WordPress admin dashboard. Then, you can again 'check for updates' and you'll get 3.1.9.1, which fixes this problem (but still handles all security issues).

Again, sorry for this mess and thank you for your patience.

March 11, 2015 at 5:48 pm #576164

christophE-2

Still the same probleme here. When will the problem be fixed?

March 11, 2015 at 7:24 pm #576257

Amir
Supporter

Christoph, can you tell us which version you are running?

March 12, 2015 at 9:48 am #576628

mattiasK-2

Yepp, i still have the same problem too.
Running version 3.1.9.2 on wordpress 4.1.1
Start page works fine but ex. hidden link
Doesnt.

March 12, 2015 at 9:52 am #576635

Amir
Supporter

I'm looking at your page:
hidden link

It looks OK to me, but I don't know what to expect. Can you tell us what's wrong with that page?

March 12, 2015 at 9:55 am #576639

mattiasK-2

Ohhh, sorry Amir,
I had to deactivate wpml since its a live site.
Its generating a 404 as soon as i activate wpml.
Disabeling wpml obviously fixes this.

the "real" domain name is "www.härenviks.se" soo i imagine the problem is with the "non-english" character in the domain name.

March 12, 2015 at 10:36 am #576695

Andrea
Supporter

Hello Mattias,

I'm Andrea, lead developer for WPML.

We have a fix for this issue, which we are going to release in the next hours.

Is it ok to wait until the fix is released?

Otherwise, I can manually apply the patch on your site: if you chose this option, please make a full backup first, then share your access details in the private details box.

March 12, 2015 at 10:40 am #576705

mattiasK-2

Its fine Andrea,
I havent started with the translation yet soo i can wait until the fix is official.
Thanks for everyones quick response.

March 12, 2015 at 10:52 am #576736

Andrea
Supporter

You are welcome!

March 13, 2015 at 3:07 pm #577921

erikaS-2

Hi !

Still have the problem. Installed the latest update - but never the less it won't work.

hidden link - > Unterkünfte in Italien -> Florenz (as example) ..... you will find 404 here... what to do?

Best wishes

Erika

March 13, 2015 at 4:41 pm #578041

erikaS-2

Problem solved... sorry..