This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Mihai Apetrei 5 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 13, 2019 at 10:32 am #3796961

edwardH-16

I am trying to:
Hi,
My issue that when you visit my site it forces it to be hidden link
I don't want that to be displayed, I only use your plugin to translate different elements to Swedish not to make a multilanguage site.
How can I remove that?

Link to a page where the issue can be seen:

I expected to see: hidden link
The normal Url, all I want is to translate different elements from English to Swedish not make a multilanguage site, the site is only in Swedish!

Instead, I got:

May 13, 2019 at 2:31 pm #3799409

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

It is safe to share exact links with me as the links are automatically hidden for the public.

1. Can you please let me know the exact links that you are referring to?

2. Can you please let me know what exactly are you trying to translate?

3. You could also hide languages from the public, if you want to do that, under WPML > Languages.

4. If you want me to take a look at a specific situation on your current setup, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 14, 2019 at 10:26 am #3805865

edwardH-16

Hi,
The issue is that it forces the site URL to be hidden link <--- I want to remove the /en in Url, you understand? I only translate diffrent element site is NOT multilanguage. And now i get 404 error, please check image.
Thank you!

May 14, 2019 at 12:57 pm #3806993

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I see. Thank you for the explanation.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 14, 2019 at 1:31 pm #3807327

edwardH-16

i just need to know witch settings to change?

May 15, 2019 at 9:24 am #3814399

edwardH-16

????

May 15, 2019 at 9:25 am #3814403

edwardH-16

Send invitation link?

May 15, 2019 at 1:56 pm #3817421

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Unfortunately, I have no information about your site and that is why I asked for site access and for the debug information.

Without that information, I am afraid that there is not much I can do but only guess.

There are many things that could cause this.

Please let me know if you can offer site access + the debug information and I can send the private fields once again.

PS: There is only one thing that comes to mind that you could check upon - Go to your WordPress backend > WPML > Languages > and in the "Language URL format" make sure that the "Use directory for default language" option is UNchecked.

Kind regards
Mihai