This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Mihai Apetrei 4 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 20, 2019 at 11:18 am #3221122

konstantinosP-5

I am trying to: Make WPML work with hidden link

Link to a page where the issue can be seen: hidden link

I expected to see: the side filter working for the shop.

Instead, I got:When I select year from the filter it stucks (ΕΤΟΣ ΕΚΔΟΣΗΣ). It works only if I deactivate WPML

February 20, 2019 at 3:25 pm #3222572

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see in the documentation of the plugin written by the developers of the plugin that you use, you should be able to use the plugin with WPML by following the recommendations in the plugin doc below:
hidden link

Let me know how that goes.

Kind regards,
Mihai Apetrei

February 22, 2019 at 7:48 am #3231220

konstantinosP-5

Hello and thank you for the answer,

The problem is not with labels.
The problem is with the filter itself. The filter does not work if we enable WPML.
To be more specific all fields (and not labels) of the field work with WPML (categories, extra tags etc) except the date one (year).

When we disable WPML the date filter works.

Could you please take a look in our staging environment?

Thank you in advance.

February 22, 2019 at 11:45 am #3232121

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I would be more than happy to take a look.

Before I do that though, can you please do the next things below:

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. Make sure that the theme you are using and all the plugins are using the latest versions. If not, please update them to the last version, only after you create a full website backup.

3. If the issue still persists, we will need to check for a possible theme or plugin conflict.

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

If things are the same after these tests, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 26, 2019 at 4:15 pm #3246034

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for all the feedback.

I can confirm that the credentials work.

Can you please register WPML on this site first and then update the plugins to the latest version?

Here is how you can register:
https://wpml.org/faq/install-wpml/#register

Please let me know when that's done so that I can continue on the debugging process.

Kind regards,
Mihai

March 1, 2019 at 2:51 pm #3261688

konstantinosP-5

Hi Mihai,

The site is registered and all plugins are up to date 🙂

Thank you

March 4, 2019 at 12:49 pm #3268699

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the extra explanations.

Also, thank you for updating everything.

I was able to see the issue happening. I can see that instead of filtering by year, it goes to posts archive instead of applying the filter as it does for all the other filters.

I think we are experiencing a compatibility issue.

I can send this issue to our compatibility team to check on but I will need you to first recreate the issue on a sandbox on our servers with a minimum WordPress install (this means just WordPress and only the necessary plugins like WooCommerce, WPML plugins + add-ons and the plugin you created the filters with: WOOF)

I created this sandbox environment for you here:
hidden link (one-click login)

I also installed and set up WPML and WooCommerce for you.

All you need to do is just create some test products, install the plugin you bought from CodeCanyon and recreate the issue.

Please let me know when that's done so that I can check it and forward it to our compatibility department.

I will be looking for your response.

Kind regards,
Mihai

March 5, 2019 at 10:12 am #3272605

konstantinosP-5

Hello Mihai,

We created products and filters in your sandbox environment. The problem persists over there as well. I am thinking it was something to do with the fact that this product property (date) is only numeric (and its url is numeric as well). All other properties are alphanumeric.

Just to know the date issue was occurred after updating WPML. It used to work with previous WPML versions, but unfortunately we cant recall the version it was working on.

Thank you.

March 5, 2019 at 4:45 pm #3275269

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the updates.

I will test this on the sandbox and I will keep you updated.

Thank for your patience in the debugging process. I really appreciate that.

Kind regards,
Mihai

March 8, 2019 at 4:04 pm #3294082

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

It seems this might be a compatibility issue.

I already sent this to the second tier.

As soon as I get an answer from them, I will also escalate this issue and change the status of the ticket.

I will keep you up to date.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

March 11, 2019 at 12:32 pm #3311281

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am changing the status as the second tier team confirmed this looks like a compatibility issue and I just escalated this to the Compatibility team.

I will keep you updated as soon as I have any feedback from my colleagues.

Thank you for your patience.

Kind regards,
Mihai

March 18, 2019 at 11:09 am #3368517

konstantinosP-5

Hello Mihai,

Could we please have an update on this?

Thank you in advance

March 18, 2019 at 5:32 pm #3371961

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sure, this was first escalated to our second tier team and after the issue was confirmed, this was escalated forward to the Compatibility developers team and they are still working on it.

I will get back to you as soon as I have any feedback from them.

Kind regards,
Mihai

April 4, 2019 at 11:25 am #3534327

konstantinosP-5

Hello Mihai

Any news on this one?

April 4, 2019 at 3:22 pm #3536525

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

The team is still working on this.

The status has also been changed here (https://wpml.org/plugin/woof-woocommerce-products-filter/) to: "Has known issues".

I will get back to you as soon as I have more feedback on this.

I will also set the status of this ticket back to "Escalated to Compatibility team"

Kind regards,
Mihai