Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.76 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by amjadA 6 years, 6 months ago.

Assigned support staff: Beda.

Author Posts
January 14, 2015 at 11:47 am #542315

amjadA

Please help me
My web site English Arabic
I have big data
I install plugin wpml after that i upload data then
The problem of theme and technical support to Theme appeared upload WooCommerce Multilingual
after that every thing is ok but in arabic web site Size & color No in all products
this Arabic
hidden link

this English hidden link

Please help me Thread fateful and data very large

color-en.png
color-ar.png
January 14, 2015 at 3:54 pm #542526

Beda

Hello Amjad

I will take care of your ticket.
Could you please share your Debug Informations with me?
http://wpml.org/faq/provide-debug-information-faster-support/

Please make sure all Plugins and the Theme is updated correctly.

Please also make sure that "Translate with WPML" is selected in WPML > Theme and Plugin localization.

Can you confirm to have correctly translated your product attributes and categories?

Do you have selected to Synchronize all taxonomies and category parents to translations in WPML > Translation Management > Multilingual Content Setup?

Could you also elaborate who you imported your data?
Was it already translated on import, or did you translate it afterwards?

Please also let me know if you would prefer a Arabic Speaking Supporter.

Thank you

January 16, 2015 at 7:41 am #543589

amjadA

Thanks For replaying
My problem was solved
Everything is good
But I have a small problem
There are some words did not translate to me and did not find it
You can see print screen
Please help me

select.png
add-cart.png
add.png
January 18, 2015 at 7:44 am #544432

amjadA

Please help me

January 18, 2015 at 2:09 pm #544484

Beda

Hello Amjad

Please double check in WPML > WooCommerce Multilingual > General Settings if all store pages have been created properly
(if no error warnings display there, all should be good.)

Please also try to search for those words (strings) in WPML > String Translation.
If you find them untranslated, please translate them and save them.

In case you don't find them, please scan the plugin "WooCommerce" for new strings in WPML > Theme and Plugin localization, after having activated "Translate with WPML"

If this all does not work please try it with this settings:

1. WP Theme Twenty Fourteen enabled
2. ALL Plugins disabled but WPML + AddOns, WooCommerce + WooCommerce Multilingual

Please let me know if it works afterwards.

Thank you

January 18, 2015 at 2:37 pm #544492

amjadA

Hello Beda
For this point
"Please also try to search for those words (strings) in WPML > String Translation.
If you find them untranslated, please translate them and save them."
Found and translators
For another points
I am afraid of the use of any process
Because the data is very important I do not have a backup
Please help me

January 18, 2015 at 5:57 pm #544556

Beda

Hello Amjad

I understand the issue was solved?
""Please also try to search for those words (strings) in WPML > String Translation.
If you find them untranslated, please translate them and save them."
Found and translators"
==> Are the strings now translated and properly displaying on your front-end?

If not, please check again all WooCommerce pages have been created, all WooCommerce Translations are installed and in WPML > String Translation all regarding Strings are translated and saved.

If you want to follow the recommended Debug Steps, please perform a full database and website backup so you are on the safe site if some data gets lost (which usually doesn't happen)

Please let me know if this works afterwards.

A backup is fully required even if we would solve the issue by having access.
We as support Team are not allowed to work on your site without having your permission and your confirmation that a backup has been made.
Always some data can get lost by error, this is why a full backup is so important.

Thank you

January 20, 2015 at 5:40 pm #546024

amjadA

""Please also try to search for those words (strings) in WPML > String Translation.
If you find them untranslated, please translate them and save them."
Found and translators"
==> Are the strings now translated and properly displaying on your front-end?
For this i found words (strings) They present in WPML with translation but in my web site it's still no translation

If not, please check again all WooCommerce pages have been created, all WooCommerce Translations are installed and in WPML > String Translation all regarding Strings are translated and saved.

For this point I will Scan them and i tell you whats happen
Thank you

January 21, 2015 at 1:08 pm #546546

Beda

Hello Amjad

I assume you have either some outdated WooCommerce Translations or not all pages of WooCommerce installed properly.

I also assume you will be able find and translate all those words (strings) in WPML > String Translation
(if the strings are generated by WooCommerce and not another 3rd party plugin/theme)

I have also double checked this issue with our Arabic Forum Supporter and he can confirm that all this words come translated by default if you correctly install and setup WooCommerce Multilingual.

Please inform me on the outcome

Thank you

January 21, 2015 at 1:30 pm #546574

amjadA

I am lost and do not know where to start, and this causes me a lot of problems

January 21, 2015 at 1:54 pm #546597

amjadA

I have another Question
I have tow plugin Discussion on Product Options for WooCommerce and WooTabs,Add Extra Tabs to WooCommerce Product Page

when i use any one in product English there no show in Arabic Why ?
Can you see this link hidden link
under the small photo you can see tab size then go the Arabic no
Why ?
please help me

January 21, 2015 at 5:52 pm #546756

Beda

Hello Amjad

Please could I gently ask you to open a new thread with the new issue?

This simplifies the search for solutions for other users.

Please provide me temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

==> Please backup your database and website <==

Please note that I can not perform the translations for you.
I can point you to the correct solution, and check the configurations in your Installation.

I will, according to this threads subject, check why the in the screenshots provided words (strings) don't get translated.

Thank you

January 22, 2015 at 11:58 am #547169

amjadA

Thank you My issue is resolved