This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.74 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by massimilianoR 5 months ago.

Assigned support staff: Vincenzo.

Author Posts
November 27, 2018 at 9:07 am

massimilianoR

Buongiorno,

ho bisogno di assistenza perchè non mi vede alcune categorie e alcuni prodotti anche se ALL-IMPORT li ha importati correttamente:

Precisamente qui si visualizzano:
hidden link

Qui non tutte:
hidden link

Ma ad esempio qui:
hidden link

Dove ci sono i prodotti:
SFE050
SFE180
ecc..
Ecco un link del prodotto:
hidden link

Ma i prodotti sono correttamente importati come puoi vedere nell'immagine1

Ma nella categoria in inglese:
hidden link

Non si vedono..e si conseguenza non fanno vedere la categoria qui;
hidden link
come mai??

November 29, 2018 at 12:40 pm #2952005

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Puoi dirmi se le categorie era già esistenti e tradotte prima dell'importazione dei prodotti?
Come puoi leggere nella documentazione allegata, ... you must create the exact same taxonomies before the import.
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#importing-posts-with-taxonomies

Nel frattempo, puoi provare a risolvere correggendo manualmente le categorie nei prodotti interessati e utilizzando lo strumento "Sincronizza le tassonomie degli articoli" che si trova in WPML -> Assistenza -> risoluzione dei problemi.
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

November 29, 2018 at 3:31 pm #2952995

massimilianoR

Ciao Ho fatto quello che mi hai detto ma continua a darmi dei problemi...

effettivamente qui è stato risolto:

Ita
hidden link
Eng:
hidden link

Ma trovo altre numerose anomalie:

Qui nella parte inglese mancano 2:
Ita
hidden link
ENG
hidden link

Anche se ci sono:
hidden link
hidden link

Ma anche in altre categorie succede questo da cosa dipende cosa posso fare per far visualizzare tutte le categorie sia in italiano che inglese?

Riguardo alla vostra domanda:
Puoi dirmi se le categorie era già esistenti e tradotte prima dell'importazione dei prodotti?

Si io ho fatto l'importazione delle categoria in italiano tramite XML e poi in inglese usato un codice univoco seguendo la vostra guida:
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#importing-posts-with-taxonomies

Infatti tutto è stato importato correttamente, ovvero le categoria in ITA e in ENG sono perfettamente sincronizzate e la traduzione è abbinata correttamente....

Vi ho lasciato le credenziali riuscite a risolvermi il problema?

il backup del sito avviene ogni giorno quindi non preoccupatevi...

November 30, 2018 at 10:34 am #2955535

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

ho dato un'occhiata al sito.

Puoi installare le ultime versioni di WPML e dei suoi add-on plugin?
- In particolare WooCommerce Multilingual
Puoi verificare quali siano le ultime versioni andando su "Conto -> Download" su questo sito.
- https://wpml.org/account/downloads/

Queste sono le istruzioni per l'aggiornamento:
- https://wpml.org/it/faq/come-installare-wpml/

❌ Assicurati d'avere un backup del sito prima di procedere! ❌

Prova inoltre i seguenti passaggi:
- Premi il pulsante "Sincronizza proprietà (Categorie prodotto) assegnata al contenuto" da WooCommerce -> WooCommerce Multilingual -> Categorie

- Seleziona l'opzione "Sincronizza categorie prodotti (visualizza tipo, anteprima)" da WooCommerce -> WooCommerce Multilingual -> Status -> Troubleshooting page e premi il pulsante Avvia

Dopo gli aggiornamenti, puoi incollare le Informazioni di debug nell'apposito campo?
- https://wpml.org/it/faq/come-fornire-le-informazioni-di-debug-per-unassistenza-piu-rapida/

Grazie

November 30, 2018 at 1:27 pm #2956198

massimilianoR

Non ho trovato la voce Troubleshooting page in WooCommerce -> WooCommerce Multilingual -> Status

Comunque ho fatto Informazioni di debug

November 30, 2018 at 2:53 pm #2956433

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

hai ragione, recentemente è stata aggiunta la traduzione e adesso la voce si chiama "Risoluzione dei problemi" e si trova in basso a destra, come puoi vedere nello screenshot che hai postato.

Grazie

November 30, 2018 at 3:07 pm #2956474

massimilianoR

Premi il pulsante "Sincronizza proprietà (Categorie prodotto) assegnata al contenuto" da WooCommerce -> WooCommerce Multilingual -> Categorie

______Non trovo questa opzione.....

- Seleziona l'opzione "Sincronizza categorie prodotti (visualizza tipo, anteprima)" da WooCommerce -> WooCommerce Multilingual -> Status -> Troubleshooting page e premi il pulsante Avvia

______Fatto ma nulla è cambiato le categorie non si vedono:

hidden link

hidden link

November 30, 2018 at 3:38 pm #2956598

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Per proseguire nel debug del problema, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- https://wordpress.org/plugins/duplicator/

★ Istruzioni:
hidden link
https://wpml.org/it/faq/come-fornire-ai-supporter-una-copia-del-vostro-sito/

Se il file risultante è troppo grande (maggiore di 400 MB) si possono utilizzare i filtri di Duplicator per evitare di includere la cache, la cartella wp-uploads, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me serve il file archive che il plugin genera. Puoi incollare il link al file nella prossima risposta.

Puoi usare servizi come Google Drive o Dropbox per inviarmelo.

Ti attivo una risposta privata così puoi inviarmi il link al file in maniera sicura.

Fammi sapere se hai bisogno di aiuto nel creare il duplicato.

Grazie

November 30, 2018 at 5:04 pm
December 1, 2018 at 4:58 pm #2958980

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

sembra che il problema sia risolto.

Questi sono i passaggi effettuati:

- Selezionare la lingua Inglese nella bacheca tramite il selettore in alto
- Andare su Prodotti -> Ordine della tassonomia
- Effettuare una piccola modifica all'ordine delle tassonomie
- Premere il pulsante Aggiorna
- Ripristinare l'ordine prededente
- Premere il pulsante Aggiorna
- Andare su WooCommerce -> Stato
- Selezionare la scheda Strumenti
- Premere il pulsante "Riconteggia i termini"

Potrebbe essere necessario ripulire la cache.

Fammi sapere se il problema è risolto o se hai bisogno di maggiori informazioni.

Grazie

December 2, 2018 at 8:49 am #2959806

massimilianoR

Ho così sembra che vada bene, ho solo due domande:

1) ma dopo posso riordinare comunque le categorie, perchè ho bisogno di dargli un ordine preciso e mi serve plug-in ordina categorie

2) come mai queste ultime categorie non hanno genitore? (allego foto)

December 3, 2018 at 11:29 am #2961885

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sono contento che il problema sia risolto.

1. Penso che non dovrebbero esserci problemi al riguardo.

2. Se dopo aver salvato l'ordine delle categorie, quelle categorie continuano a non avere un ordine, il problema potrebbe essere causato dal valore insufficiente di MaxVars nel file php.ini
- Prova a verificare se il problema si verifica anche con WPML disattivato.
- Prova a raddoppiare il valore attuale di MaxVars

Visto che il problema originale è risolto, posso chiederti di chiudere questo e aprire un nuovo ticket per le altre domande?
- La politica di assistenza prevede che si posti un solo problema per ciascun ticket.
Puoi farlo da questo indirizzo: https://wpml.org/it/forums/forum/supporto-in-italiano/
- Ti basta cliccare su "Apri un nuovo ticket di assistenza"

Questo aiuterà altri utenti con problemi simili a trovare le soluzioni quando cercano nel forum.

Grazie

May 22, 2019 at 7:20 am #3861753

massimilianoR

Buongiorno Vincenzo,

ci siamo accorti che abbiamo una famiglia di articoli che nella parte di sito in inglese non viene visualizzata, sembrava tutto ok, ma essendo più di 2.000 prodotti inizialmente non avevamo visto questi che ti allego:

hidden link

Se andiamo a fare la ricerca per singolo articolo, vediamo che questi sono presenti a sistema:
hidden link

Di seguito tutti gli articoli che sono inseriti nella famiglia e che vengono visualizzati nella parte di sito in italiano:
hidden link

Ti invio anche in aggiunti i silenziatori, in cui abbiamo il problema analogo, ma solamente la famiglia del “SILENZIATORE IN PLASTICA – ESAGONO” vediamo la tabella articoli sia nella parte in italiano che in inglese:

Mi potresti verificare nome mai abbiamo questo problema?
Grazie.