This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 43 replies, has 2 voices.

Last updated by Yvette 2 weeks, 1 day ago.

Assigned support staff: Yvette.

Author Posts
July 9, 2019 at 12:32 pm #4170719

juanS-11

Buenos días

Estamos teniendo un problema con wpml y divi. No sabemos porqué, pero de vez en cuando sin ton ni son, da igual que sea un global section, que una sección de página, se cambia el idioma del bloque de texto a alguno de los otros dos idiomas.

Nuestra web está en 3 idiomas: inglés, francés y español (principal).

Os adjunto una captura de las traducciones de cadena, que parece ser crea sin más un par de entradas nueva, y aunque las traduzcamos a sus respectivos idiomas, luego se vuelven otra vez a montar en uno de los otros dos idiomas.

July 9, 2019 at 3:45 pm #4172747

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Es curiouso.

Estos bloques de textos son iguales (en contenido) pero en otros páginas/secciones? Es decir, en tu captura, los textos parecen ser idénticos pero procediendo de diferentes páginas.

- Acceso temporal a tu sistema
Podría pedir acceso a tu sistema temporalmente (wp-admin y FTP). Si pudiera ser a un sistema de pruebas donde el problema ha sido duplicado - mejor. Encontrarás los campos necesarios para facilitar este acceso en la area justo debajo la zona de comentarios cuando entras a dejar tu próximo respuesta.
La información será privado. Es decir que los datos será solo visible entre tu y yo.

July 10, 2019 at 10:19 am #4178517

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Acabo de hacer lo siguiente:

- crear nuevo post en idioma EN
- incorporar módulo desde la bibiloteca (CTA ENG)
- guardarlo

Como esperaba, el mismo texto aparecía en la tabla de cadenas con el dominio textos "page-builder-shortcode-strings-14105" donde 14105 es el post-id del nuevo post. Tiene el idioma de EN como he creado la página en EN.

Hasta ahora, todo normal. Cuando aparece la anomalía que describes?

July 10, 2019 at 11:04 am #4179163

juanS-11

Buenas tardes Yvette.

Entra en la página que denominamos "inicio", y modifica la sección global que está al final de la página en verde. Y ahora vas a la traducción en inglés (pulsas la bandera de arriba en inglés) y modifica la misma sección y dale a actualizar. Y esto hará que el texto insertado en la parte en español, se va a inglés, esto pasa en algunas secciones.

Por ejemplo, también en la misma "inicio", verás que hay una sección como la que adjunto en la pantalla, ocurre lo mismo, si tocas la original (español) y luego lo demás. Nuestro idioma por defecto no es el inglés. Insistimos que no ocurre siempre. Y lo del global es de locos, porqué en algunas páginas falla (home, gruposeripafer.com.es/packaging), y en otras no.

También pasa con la primera sección de inicio , el shortcode de layerslider, si pones el mismo en los tres idiomas [layerslider id="inicio"], y en traduccion de cadenas traduces el slider, el útlimo que guardas en la traducción de cadenas, ese se queda para todos los sliders.

July 10, 2019 at 5:29 pm #4183299

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola

Ok - creo que se trata de como estas usando o no usando el Translator Editor para varios elementos del Divi

1. Global Elements
Deberías cambiar los contenidos en cada idioma en la versión de la biblioteca usando el Translation Editor. No tienes que introducir ningún cambio en la página...y solo marcar como "completo" la version EN tal cual como aparecen en el traductor. Parece ser que la versión de la biblioteca tendrá prioridad.

2. Otros Sectores
Activé el Translation Editor y consigo cambiar el sector en cada idioma (cambié solo algunas palabras y no el totalidad).

3. Slider
Leí este artículo
https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-using-layerslider-and-wpml/

Selon las indicaciones, cambié el idioma "original" de las cadenas a "es" y luego traducí las cadenas (ver imagen).

Los sliders aparecen bien traducidos ahora.

July 11, 2019 at 6:27 am #4186253

juanS-11

Hola Yvette, gracias por contestar rápido. Entra ahora a gruposeripafer.com.es/en y verás como te sale el slider en español, y no en inglés, acabo de entrar ahora. Te paso captura de pantalla

Pues siguiendo tus instrucciones fíjate ahora como está la home de gruposeripafer.com.

Te voy pasando capturas de pantallas.

Verás que después de utilizar el traductor la home ayer en ES estaba en español y hoy por la mañana aparece en inglés. Te adjunto también capturas de pantalla de como está la traducción de cadenas buscando por el titulo que hay ahora de la sección de la home que te marco en las capturas.

Y ese es el problema, que lo cambiamos y al momento está correcto, pero un rato después ya no aparece como debería.

Muchas gracias

Saludos!

July 11, 2019 at 7:29 am #4186657

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Una clarficiación:

Estas modificando las entradas directamente en la tabla de traducciones? o siempre estas usando el editor de traducciones para realizar cambios?

Entiendo que para los sliders, tienes que realizar los cambios directamente en la tabla...pero para los otros elementos....?

Ahora mismo, en modo Icongito, a mí me sale el sector de la página correcto (ver imagenes).

July 11, 2019 at 7:40 am #4186785

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Miré en la tabla de traducciones y ví que había nuevas cadenas en el dominio "default" que eran idénticos a la cadenas del slider.

Cuando los eliminé, los traducciones volvieron a lo que deberían ser.

Así que, el problema reduce a descubrir cual acción causa que estos nuevos cadenas aparecen.

Había algún modificación realizado en las sliders esta mañana? Caso afirmativo, cual era los pasos realizados?

Gracias

July 11, 2019 at 7:47 am #4186867

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

He podido recrear el problema con las cadenas de los sliders haciendo los siguientes pasos:

- ir a Layer Slider WP > Sliders >
- editar "Inicio - Slider Eng"
- Actualizarlo

En principio - no deberías tener los sliders "Inicio - Slider Eng" ni "Inicio - Slider FR" Solo falta un slider: "Inicio" y deberías modificar los traducciones por medio de editar directamente la tabla de cadenas.

July 11, 2019 at 12:51 pm #4189885

juanS-11

Pues lo hacemos como indicas y nos ocurre lo mismo.

De todos modos, acabo de entrar a gruposeripafer.acceseo.com.es (no al admin), y los sliders están todos en español, da igual en el idioma en el que estés.

July 11, 2019 at 4:01 pm #4191719

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1.Como traducir sliders
Destaco que NO debes hacer los pasos descrito aquí:
https://wpml.org/forums/topic/problemas-con-los-sections-de-divi-cambio-de-traducciones-sin-mas/#post-4186867

Sería mejor ELIMINAR los sliders con título "Inicio - Slider Eng" y ""Inicio - Slider Fr"

2. Cuando yo visito el URL: gruposeripafer.acceseo.com.es
veo los textos de los sliders en el idioma que corresponde. Esto resulta cuando elimino las cadenas que aparecen en el imagen.

July 11, 2019 at 4:19 pm #4191825

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmmm - ahora veo que no funciona como eseparaba.
Tengo permiso de eliminar los sliders ""Inicio - Slider Eng" y ""Inicio - Slider Fr"?

July 12, 2019 at 6:38 am #4195555

juanS-11

Por supuesto, en el subdominio que te pasé haz lo que necesites, es un clon de la web original, elimina, cambia, etc...

Lo curioso es que tenemos unos 60 wpml y no nos ha pasado lo que ocurre en este.

Tenemos un poco de urgencia con el tema porqué el cliente está empezando a ponerse un poco nervioso.

July 12, 2019 at 8:21 am #4196279

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK. Gracias.

Curiosamente - ahora mismo, desde wp-admin, los sliders aparecen bien. No obstante, con el modo icognito, aún demuestra textos equivocados.

Noto que hay un actualización disponible para Layer Slider. Por favor, puedes actualizar lo y avisarme cuando está hecho?

Gracias

July 12, 2019 at 8:52 am #4196611

juanS-11

Perfecto, lo pedimos al cliente que es quien tiene la licencia y lo actualizamos.

Simplemente por recordatorio, que no solo pasa en los sliders, que también ocurre con los divi global sections (por ejemplo la de CTA Esp por si quieres probar).

Saludos

The topic ‘[Closed] problemas con los sections de divi: cambio de traducciones sin más’ is closed to new replies.