Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: 404 error after changing default language

Solution: Go to Settings -> Permalinks and click save to solve the 404 error

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.26 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by bjornT-7 1 year, 3 months ago.

Assigned support staff: Andreas W..

Author Posts
April 25, 2019 at 3:24 pm

bjornT-7

I almost completed my website and made all the translations with WPML.
But now I realised that it would be better to change the default language to our own (Dutch) language.
I read in another topic here (https://wpml.org/forums/topic/change-default-language-7/) that it shouldn't make any problem.
And it didn't... only for one page, the most important page...
hidden link
It redirects to the Dutch translation... only this page... all the other don't do that.

I use Turbo Car Rental theme/plugin.

Is this something that I can solve?

April 26, 2019 at 5:12 am #3687789

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

It seems the issue was solved after simply re-saving the permalinks inside of the WordPress settings.

Could you please confirm that everything is working as expected?

Otherwise, please let me know if you need any further assistance.

Kind regards
Andreas

April 26, 2019 at 5:37 am #3687927

bjornT-7

My issue is resolved now. Thank you for the assistance!

April 28, 2019 at 8:23 am #3697391

bjornT-7

Hello,
the issue is back again en resaving the permalinks doesn't work