Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 40 replies, has 3 voices.

Last updated by Andreas Neuber 5 years, 11 months ago.

Assigned support staff: Andreas Neuber.

Author Posts
February 17, 2014 at 2:06 pm #341509

Dimitri

Perfect, i look forward to hearing from you.

February 18, 2014 at 8:56 am #342083

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

We have released a beta version for WPML 3.1.4. This version includes fixes for everything that was reported for the problematic WPML 3.1 release.

You can get it from your WPML account. Go to Downloads, scroll to the bottom and you will see the beta package. Right now, it's 3.1.4-b1.

This ZIP includes several ZIP files of the individual WPML components. First, unzip it locally, get the parts that you need and upload them.

The safest way to update the plugins is to*:
1. Deactivate (don't worry, your content doesn't change)
2. Delete the folders with the older versions
3. Upload the new versions
4. Activate

Please let us know if this version solves the problem. If anything remains, we want to know about it and we will handle it as fast as possible.

We are sorry for the trouble that this had caused you and appreciate your help verifying that the problem is handled.

--
* good to backup your site beforehand - I personally recommend to use plugin "Duplicator" for that

February 21, 2014 at 10:03 am #344841

Dimitri

Hi,

I still noticed that:

1) some links works weird, If I'm into this page: hidden link
the language switcher menù doesn't show other languages (but they are!)

2) If I'm here: hidden link and I switch to Italian version I'm redirected to another page (not the translated one)

I'm getting crazy..

Thank you

D.

February 21, 2014 at 1:09 pm #345051

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

Right there is no reason why there is only English in the switcher..

# Could you switch 1x to the default theme of WP?
Just quickly after a DB backup.

February 21, 2014 at 7:04 pm #345333

Dimitri

Hi,

even with the standard wordpress theme doesn't work.

Could you please make some controls?

And more.. If set "italian" as my default language (as it should be) the strings keeps in english even if I've translated them.. I've seen that if I set english as default language this problem disappears.

Why does happend this?

Thank you

D.

February 24, 2014 at 11:03 am #346147

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

In the recent days several bugs were fixed and we really recommend to use WPML 3.1.4-b5

# Could you install them? Sorry that again another version should be installed.
You can get it again from your WPML account. Go to Downloads, scroll to the bottom and you will see this beta package.

This ZIP includes several ZIP files of the individual WPML components. First, unzip it locally, get the parts that you need and upload them.

The safest way to update the plugins is to:
1. Deactivate (don't worry, your content doesn't change)
2. Delete the folders with the older versions
3. Upload the new versions (main plugin: "sitepress-multilingual-cms" folder)
4. Activate

Please let me know if this version solves the problem. If anything remains, esp. with the WP default theme then I will definitely involve our developers - because this must be then a bug.

Sorry for this back and forth!

February 24, 2014 at 8:51 pm #346584

Dimitri

Upgrade installed but problems keep there.. what about looking at my website in order to understand what we are talking about?

Thank you

D.

February 25, 2014 at 1:12 pm #347038

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

We have been looking at your website couple of times and I see the problem - but we need to be sure also that there is not a bug which was resolved recently.

Our developers have opened a new bug ticket for your site and will check today again in depth.

February 26, 2014 at 11:03 am #347739

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

Since yesterday a new ticket was opened for this issue, our senior developer had a look and applied a fix on your site.

I had a look at hidden link - this seems to have solved it, as far I can see.
Could you also have a look and let me know if this is really (and completely) the case?

February 27, 2014 at 9:26 am #348421

Dimitri

Hi!

that problem has been solved, keeps the other one:

my website has "italian" as default language, strings are in english and have been translated, but in italian version they keep displayed in english, if I set "english" as default language strings work well...

Why does it happens?

Thank you for the support

Dimitri

February 27, 2014 at 1:30 pm #348705

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

Happy to hear that.

When using String - Translation then the "default language" for the strings should be "English" - at least in 99% of all cases.
Very most themes & plugins today are written with __('text') , _e() Gettext calls in English.

This has nothing to do with the posts. Here you can choose freely what is your default and secondary language.

February 27, 2014 at 2:36 pm #348764

Dimitri

Hi Andreas,

I've already followed your guidelines. My strings are all in english, and WPML is set in english concerning the language strings.. but the problem persists.

D.

February 28, 2014 at 12:06 pm #349377

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

Could you provide us with an example of a string that doesn't show its translations?
Easier to troubleshoot of we target one in particular.

# http://wpml.org/forums/topic/problems-after-last-upgrade/page/2/#post-348421
You mention there: --> "if I set "english" as default language strings work well…"
Currently, you have "Inglese" as "Original string language" under "WPML > String Translation".
Did you mean "english" as default language for your posts?

February 28, 2014 at 3:04 pm #349534

Dimitri

Try to see this page:

hidden link

as you can see we are into the "italian" version. But there is still an english string "Find refereces"

Now if you try to set "english" as default language, you'll see that the strings will work well.

D.

March 3, 2014 at 9:56 am #350527

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Dimitri,

I've checked the string and..

1) themes/tk/archive-testimonianze.php
..has a correct gettext call:

<?php _e('Find references','TK'); ?>

2) String-Translation
Correct settings, correct and completed Italian translation

3) Text-Domain
Since this is actually the only thing coming to my mind, why the translation is not loading..
Do you know by any chance which file of your TK theme contains "load_theme_textdomain()" ?

The topic ‘[Closed] Problems after last upgrade’ is closed to new replies.